Bug 1464213 - Snapshot remains locked after failed live merge
Snapshot remains locked after failed live merge
Status: CLOSED DUPLICATE of bug 1464214
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
4.1.3
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Kenigsberg
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 12:29 EDT by Kevin Alon Goldblatt
Modified: 2017-06-25 04:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-25 04:39:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Alon Goldblatt 2017-06-22 12:29:35 EDT
Description of problem:
Snapshot remains locked after failed live merge due to restart of vdsm

Version-Release number of selected component (if applicable):

Verified with the following code:
-------------------------------------------------------------
ovirt-engine-4.1.3.4-0.1.el7.noarch
rhevm-4.1.3.4-0.1.el7.noarch
vdsm-4.19.19-1.el7ev.x86_64


How reproducible:
Every time

Verified with the the following scenario:
------------------------------------------------------------
1. Create VM_14 with 5 disks , thin and preallocated, block and nfs
2. Create 3 snapshots, sna1, sna2, sna3
3. Start the snapshot vm22
4. Delete sna2 and a few seconds later restart the vdsm on the host . The delete fails of the snapshot fails and the snapshot sna2 remains in a locked state



Actual results:
The delete fails of the snapshot fails and the snapshot sna2 remains in a locked state


Expected results:
When the vdsm comes up again the snapshot should be in a normal state and allow a retry of the delete


Additional info:
Comment 1 Allon Mureinik 2017-06-25 04:39:55 EDT

*** This bug has been marked as a duplicate of bug 1464214 ***

Note You need to log in before you can comment on or make changes to this bug.