Bug 1464218
| Summary: | snapshot remains locked after failed live merge | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Kevin Alon Goldblatt <kgoldbla> | ||||
| Component: | BLL.Storage | Assignee: | Ala Hino <ahino> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Kevin Alon Goldblatt <kgoldbla> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | 4.1.3 | CC: | amureini, bazulay, bugs, lsurette, srevivo, tnisan, ycui, ykaul | ||||
| Target Milestone: | ovirt-4.2.0 | Flags: | rule-engine:
ovirt-4.2+
|
||||
| Target Release: | --- | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | storage | ||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-12-20 11:18:39 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
|
Description
Kevin Alon Goldblatt
2017-06-22 16:51:37 UTC
Created attachment 1290787 [details]
server, engine, vdsm logs
adding logs
(In reply to Kevin Alon Goldblatt from comment #0) Correction to previous comment! > Description of problem: > Snapshot remains locked after failed live merge > > Tested with the following code: > ------------------------------------------------------------- > ovirt-engine-4.2.0-0.0.master.20170612192318.gitf773263.el7.centos.noarch > vdsm-4.20.0-1049.gite64d80e.el7.centos.x86_64 > > Verified with the the following scenario: > ------------------------------------------------------------ > 1. Create VM2 with 5 disks , thin and preallocated, block and nfs > 2. Create 3 snapshots, snapper1, snapper2, snapper3 > 3. Start the VM2 > 4. Delete snapper2 and few seconds later restart the vdsm on the host . The > delete and Live Merge fails > 5. When the vdsm comes up again try deleting same snapshot snapper2 but can't as it remains locked > > Actual Result: > ---------------------- > Live Merge fails and snapshot remains locked > > Expected Result: > ---------------------- > Once VDSM restarts the snapshot should not be locked and allow another > delete opperation Change product to Ovirt-engine and component to storage *** Bug 1464214 has been marked as a duplicate of this bug. *** Should have been solved with the latest batch of patches, moving to MODIFIED for QE to test. INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason: [No external trackers attached] For more info please contact: infra INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason: [No external trackers attached] For more info please contact: infra Verified with the following code:
-----------------------------------
ovirt-engine-4.2.0-0.5.master.el7.noarch
vdsm-4.20.8-53.gitc3edfc0.el7.centos.x86_64
Verified with the following scenario:
-----------------------------------
1. Created vm with several disks
2. Created 3 snapshots
3. Start the vm
4. Deleted snapshot 2 - second one and restarted the vdsm during the live merge
>>>> vdsm restarts on the host and the live merge operation completes successfully. All images are merged
Moving to VERIFY
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017. Since the problem described in this bug report should be resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |