Bug 1464218 - snapshot remains locked after failed live merge
snapshot remains locked after failed live merge
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.1.3
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Ala Hino
Kevin Alon Goldblatt
storage
:
: 1464214 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 12:51 EDT by Kevin Alon Goldblatt
Modified: 2017-12-20 06:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:18:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
server, engine, vdsm logs (1.23 MB, application/x-gzip)
2017-06-22 12:55 EDT, Kevin Alon Goldblatt
no flags Details

  None (edit)
Description Kevin Alon Goldblatt 2017-06-22 12:51:37 EDT
Description of problem:
Snapshot remains locked after failed live merge

Verified with the following code:
-------------------------------------------------------------
ovirt-engine-4.2.0-0.0.master.20170612192318.gitf773263.el7.centos.noarch
vdsm-4.20.0-1049.gite64d80e.el7.centos.x86_64

Verified with the the following scenario:
------------------------------------------------------------
1. Create VM2 with 5 disks , thin and preallocated, block and nfs
2. Create 3 snapshots, snapper1, snapper2, snapper3, snapper3 
3. Start the VM2
4. Delete snap14_2 a few seconds later restart the vdsm on the host . The delete fails
5. Try deleting same snapshot snap14_2 >>>>> Live Merge fails and snapshot remains locked after vdsm restarts

Actual Result:
----------------------
Live Merge fails and snapshot remains locked after vdsm restarts

Expected Result:
----------------------
Once VDSM restarts the snapshot should not be locked and allow another delete opperation
Comment 1 Kevin Alon Goldblatt 2017-06-22 12:55 EDT
Created attachment 1290787 [details]
server, engine, vdsm logs

adding logs
Comment 2 Kevin Alon Goldblatt 2017-06-25 04:50:02 EDT
(In reply to Kevin Alon Goldblatt from comment #0)

Correction to previous comment!


> Description of problem:
> Snapshot remains locked after failed live merge
> 
> Tested with the following code:
> -------------------------------------------------------------
> ovirt-engine-4.2.0-0.0.master.20170612192318.gitf773263.el7.centos.noarch
> vdsm-4.20.0-1049.gite64d80e.el7.centos.x86_64
> 
> Verified with the the following scenario:
> ------------------------------------------------------------
> 1. Create VM2 with 5 disks , thin and preallocated, block and nfs
> 2. Create 3 snapshots, snapper1, snapper2, snapper3
> 3. Start the VM2
> 4. Delete snapper2 and few seconds later restart the vdsm on the host . The
> delete and Live Merge fails
> 5. When the vdsm comes up again try deleting same snapshot snapper2 but can't as it remains locked
> 
> Actual Result:
> ----------------------
> Live Merge fails and snapshot remains locked
> 
> Expected Result:
> ----------------------
> Once VDSM restarts the snapshot should not be locked and allow another
> delete opperation
Comment 3 Kevin Alon Goldblatt 2017-06-25 04:52:24 EDT
Change product to Ovirt-engine and component to storage
Comment 4 Tal Nisan 2017-06-25 07:33:52 EDT
*** Bug 1464214 has been marked as a duplicate of this bug. ***
Comment 8 Allon Mureinik 2017-10-29 10:21:34 EDT
Should have been solved with the latest batch of patches, moving to MODIFIED for QE to test.
Comment 9 rhev-integ 2017-11-02 09:40:05 EDT
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No external trackers attached]

For more info please contact: infra@ovirt.org
Comment 10 rhev-integ 2017-11-02 17:09:21 EDT
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No external trackers attached]

For more info please contact: infra@ovirt.org
Comment 11 Kevin Alon Goldblatt 2017-11-29 08:22:34 EST
Verified with the following code:
-----------------------------------
ovirt-engine-4.2.0-0.5.master.el7.noarch
vdsm-4.20.8-53.gitc3edfc0.el7.centos.x86_64

Verified with the following scenario:
-----------------------------------
1. Created vm with several disks
2. Created 3 snapshots
3. Start the vm
4. Deleted snapshot 2 - second one and restarted the vdsm during the live merge
>>>> vdsm restarts on the host and the live merge operation completes successfully. All images are merged


Moving to VERIFY
Comment 12 Sandro Bonazzola 2017-12-20 06:18:39 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.