Bug 146425 - Cannot install Fedora Core 3 from hard disk
Cannot install Fedora Core 3 from hard disk
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 20:05 EST by Anderson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 11:36:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anderson 2005-01-27 20:05:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.7.5)
Gecko/20050109 Fedora/1.7.5-3

Description of problem:
I am using Fedora Core 2. Now, I want to install Fedora Core 3.
I downloaded the four Fedora Core 3 image discs and saved under
/home/anderson/Minhas_coisas/Downloads/kget. I didn't change their
names. I has a CD-RW only, so I used the 'boot.iso' image, located in
CD1 under '/images'.
After this, I restarted my computer. I booted this CD and all worked
ok, but... when I choose the source partition and the source path,
Anaconda returns 'No such file or directory' error.
After, I saw the kernel messages (ALT+F4). I saw Anaconda tries to
mount a ext2 partition, after, a vfat partition, and then fails,
because my system runs in a ReiserFS partition.
I couldn't continue the installation process, because Anaconda didn't
find the source images.
ALT+F2 didn't open a shell, so I was unable to load the reiserfs module.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 2 under a ReiserFS partition
2.Download the four Fedora Core 3 iso images. Save them in the root
partition (I didn't do this, but I think there won't have difference).
3.Extract FC3-i386-disc1.iso and burn a CD-RW with the file
(FC3disc1)/images/boot.iso
4.Boot the computer using this CD-RW
5.Try to start a hard disk installation.
    

Actual Results:  Anaconda couldn't mount the partition where the
images are.

Expected Results:  Anaconda should mount my ReiserFS partition, find
the images and continue the installation.

Additional info:

I am brazilian; If I wrote something wrong, sorry...
No more additional information. Folloy the steps to reproduce the bug
and you will get it. I am sure.
Comment 1 Anderson 2005-01-27 20:07:51 EST
As a workaround, I created a ext2 partition and put the images there.
It was a hard work!!!
Comment 2 Chris Lumens 2005-01-28 11:36:15 EST
The only filesystems that are supported right now in the first stage of the
loader are ext2 (and therefore ext3), vfat, and iso9660.  This is because we
aren't yet at a point where kernel modules can be loaded so only filesystems
built into the kernel are usable.  Unfortunately, there are space constraints
for our boot kernel so only a very few filesystems can be supported.

Note You need to log in before you can comment on or make changes to this bug.