Bug 1464255 - ESC crashes occasionally with pcscd messages
ESC crashes occasionally with pcscd messages
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcsc-lite (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 15:53 EDT by Roshni
Modified: 2017-09-19 10:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-19 10:45:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2017-06-22 15:53:47 EDT
Description of problem:
ESC crashes with pcscd messages

Version-Release number of selected component (if applicable):
pcsc-lite-1.8.8-6.el7.x86_64

How reproducible:
occasionally

Steps to Reproduce:
1. ESC crashes
2.
3.

Actual results:


Expected results:


Additional info:
Jun 22 11:32:32 localhost abrt-server: Email was sent to: root@localhost
Jun 22 11:32:38 localhost pcscd: 99999999 commands.c:1449:CCID_Receive Card absent or mute
Jun 22 11:32:38 localhost pcscd: 00000987 ifdwrapper.c:527:IFDTransmit() Card not transacted: 612
Jun 22 11:32:38 localhost pcscd: 00000006 winscard.c:1606:SCardTransmit() Card not transacted: 0x80100016
Jun 22 11:32:38 localhost pcscd: 00003887 winscard.c:926:SCardDisconnect() Error resetting card.
Jun 22 11:32:38 localhost pcscd: 00007000 winscard.c:926:SCardDisconnect() Error resetting card.
Jun 22 11:32:41 localhost journal: g_slice_set_config: assertion 'sys_page_size == 0' failed
Comment 3 Roshni 2017-08-30 12:54:54 EDT
Bob,

I can try to reproduce it as i have seen it inconsistently. Please give me a command to get the stack trace when I see the issue.

Thanks
Roshni
Comment 4 Bob Relyea 2017-08-30 14:08:40 EDT
The easiest is to run ESC under gdb. ESC is really xulrunner iirc. It's probably easiest to run ESC normally, then attach to it with gdb (do a ps looking for xulrunner than :

gdb <path to xulrunner> <process id of ESC>


let gdb to, when ESC crashes, gdb will break at that point and you can use the 'where' command to get a stack backtrace.

(adding Jack to correct any errors here).

bob
Comment 5 Jack Magne 2017-08-30 17:58:29 EDT
That is correct bob. I believe cfu and myself just yesterday saw something similar on the latest Fedora when replacing a token. It works the first time and then if you take it out and put it back in, it can sometimes go down. No changes to esc lately that would account for this. Of course it could have been doing somethign wrong that has been let go all this time.
Comment 6 Roshni 2017-09-19 10:45:24 EDT
I was not able to reproduce this issue, so closing for now.

Note You need to log in before you can comment on or make changes to this bug.