Bug 1464297 - anaconda is disabling ipv6 even though not asked to
anaconda is disabling ipv6 even though not asked to
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F26FinalBlocker
  Show dependency treegraph
 
Reported: 2017-06-22 22:21 EDT by Dusty Mabe
Modified: 2017-06-28 16:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-26.21.10-1 anaconda-26.21.10-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 23:52:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2017-06-22 22:21:52 EDT
Description of problem:

Anaconda configures system to not use ipv6 even though 'noipv6' was NOT provided on the command line:

From cloud image from the 20th [1]:

```
# cat /etc/sysctl.d/anaconda.conf
# Anaconda disabling ipv6 (noipv6 option)
net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1
# ip addr show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 52:54:00:33:9b:22 brd ff:ff:ff:ff:ff:ff
    inet 192.168.121.137/24 brd 192.168.121.255 scope global dynamic eth0
       valid_lft 2463sec preferred_lft 2463sec
```

From a cloud image from the 18th [2]:

```
[fedora@cloudhost sysctl.d]$ ls -l /etc/sysctl.d/
total 0
lrwxrwxrwx. 1 root root 14 Jun 15 15:48 99-sysctl.conf -> ../sysctl.conf
$ ip addr show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 52:54:00:d1:eb:86 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.8/24 brd 192.168.122.255 scope global dynamic eth0
       valid_lft 2976sec preferred_lft 2976sec
    inet6 fe80::5054:ff:fed1:eb86/64 scope link 
       valid_lft forever preferred_lft forever
```

[1] https://kojipkgs.fedoraproject.org/compose/branched/Fedora-26-20170620.n.0/compose/CloudImages/x86_64/images/Fedora-Cloud-Base-26-20170620.n.0.x86_64.qcow2
[2] https://kojipkgs.fedoraproject.org/compose/branched/Fedora-26-20170618.n.0/compose/CloudImages/x86_64/images/Fedora-Cloud-Base-26-20170618.n.0.x86_64.qcow2


Version-Release number of selected component (if applicable):
anaconda-26.21.9-1.fc26 

How reproducible:
always

This is most likely a side-effect from https://github.com/rhinstaller/anaconda/commit/9580b33
Comment 1 Dusty Mabe 2017-06-22 22:23:02 EDT
Note that this is also causing our container minimal images to fail because /etc/sysctl.d/ directory does not exist there: https://koji.fedoraproject.org/koji/taskinfo?taskID=20101174
Comment 2 Radek Vykydal 2017-06-23 03:57:34 EDT
(In reply to Dusty Mabe from comment #0)
 
> This is most likely a side-effect from
> https://github.com/rhinstaller/anaconda/commit/9580b33

Exactly, thanks for spotting it.

https://github.com/rhinstaller/anaconda/pull/1112
Comment 3 Dusty Mabe 2017-06-23 14:17:25 EDT
can we get that submitted as an update?
Comment 4 Fedora Blocker Bugs Application 2017-06-23 14:19:02 EDT
Proposed as a Blocker for 26-final by Fedora user dustymabe using the blocker tracking app because:

 Don't know if there is a criteria this offends, but disabling ipv6 is not good. I'm going to propose as blocker and we can de-escalate to FE if needed.
Comment 5 Adam Williamson 2017-06-23 15:32:51 EDT
I'd say it's a conditional violation of pretty much any networking-related criterion (if IPv6 is disabled during install, all the 'remote repository' criteria; if IPv6 is only disabled on the installed system, all the 'must be able to install updates' criteria) in the case that the network is IPv6-only, which is becoming increasingly common. On that basis I'd be +1 blocker.
Comment 6 Fedora Update System 2017-06-26 11:19:20 EDT
anaconda-26.21.10-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aec86381a
Comment 7 Adam Williamson 2017-06-26 20:50:03 EDT
Discussed at 2017-06-26 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-06-26/f26-blocker-review.2017-06-26-16.03.html . Accepted as a blocker along the lines of #c5: this is a conditional breakage of all the criteria that involve network access, when said access can only be achieved via IPv6. We decided this was now common enough to warrant making the bug a blocker.
Comment 8 Fedora Update System 2017-06-27 02:25:57 EDT
anaconda-26.21.10-1.fc26, anaconda-user-help-26.1-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aec86381a
Comment 9 Fedora Update System 2017-06-27 23:52:10 EDT
anaconda-26.21.10-1.fc26, anaconda-user-help-26.1-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Dusty Mabe 2017-06-28 16:47:58 EDT
verified that ipv6 is now enabled and the container minimal image built fine last night: https://koji.fedoraproject.org/koji/taskinfo?taskID=20226164

Note You need to log in before you can comment on or make changes to this bug.