Bug 1464307 - synced google calendar events don't show in evolution
synced google calendar events don't show in evolution
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 23:49 EDT by Matthew Bunt
Modified: 2017-06-26 13:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 09:41:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the event test is from the google account (1.46 MB, image/png)
2017-06-22 23:49 EDT, Matthew Bunt
no flags Details

  None (edit)
Description Matthew Bunt 2017-06-22 23:49:43 EDT
Created attachment 1290871 [details]
the event test is from the google account

Description of problem: 
After setting up my google account on gnome online accounts, I am unable to see events from my google calendar on the evolution calendar. However, in the clocks drop down calendar and the stand alone gnome calendar I am able to see the synced events. 


Version-Release number of selected component (if applicable):
Evolution 3.24.3-1.fc26

How reproducible:
Always for me at least. I've tried removing and re-adding the account. Maybe I will grab a new iso of F26 and have a look at that in boxes to check if this bug is reproducible on a new install.

Steps to Reproduce:
1. Setup google account in goa
2. Open Evolution
3. Click on calendar and try to view events from the synced google account

Actual results:
The google account shows on the left hand side of the evolution calendar window but no events show on the actual calendar. Ticking the check boxs to show or hide the calendars associated with the account has no effect. Nor does refreshing the calendar. 

Expected results:
After setting up a google account in goa all calendar events from that account should show up on the evolution calendar.

Additional info:
The affected system was upgraded from Fedora 25 to 26 alpha shortly after the alpha was announced and has been updated daily since then. On another system, running Fedora 25 with Evolution 3.22.6 this behaviour is not present and I can view google calendar events as expected.
Comment 1 Milan Crha 2017-06-23 04:31:25 EDT
Thanks for a bug report. It works fine for me. The screenshot hides the top bar of the evolution, where can be seen the "Show:" value. Could you try to type there anything, like "aaa", then press Enter. After it press the icon on the right of that entry, which will clear the content and will run without any filtering, please?

As long as GNOME shell shows an event and evolution has enabled the same calendars it will also show the same events for the same time range.
Comment 2 Matthew Bunt 2017-06-23 09:41:03 EDT
Alright, my calendars are working now. I am uncertain how it happened, but it seems a search got 'stuck' as you noticed. This search box does seem a bit quirky, as it remembered my search after restarting the program and I had to do another search as you suggested and then click the button to clear the search. I would have expected the search to update in a more live fashion.

For example, yesterday before I filed this report I had noticed that I had somehow typed in the search field, and after deleting the characters in the field nothing changed. Having to click a button to clear a filter seems unintuitive and perhaps even dated.

However, that is all my opinion and obviously this is not a real bug, but a mistake on my part. Thank you for your quick response Milan Crha.
Comment 3 Milan Crha 2017-06-26 03:31:35 EDT
If there is turned on searching and it is not indicated the the search bar, then it's a bug. I missed one thing, did you delete the characters in the Search entry, but didn't hit Enter key? That's used to confirm the change, thus (re-)execute the search. I tried it here and the Search entry is populated with the search term the next start, thus it can gen confusing "only" within one run.
Comment 4 Matthew Bunt 2017-06-26 13:22:43 EDT
I still don't think this is a bug, although I found the search behaviour somewhat unexpected. For example, if I search for something on the calendar, then press enter the search works as expected. However, after I close evolution and go back in that same search is still present, I would expect the search to be reset to show everything upon opening up the application again.

Another thing, most software these days has what I would call a live search, or live filter. So as I type the search becomes more narrow and as I delete characters the search becomes more broad. This is how I was expecting the search to work on evolution but I was mistaken.

Thanks again for your help, but I still don't think this is truly a bug. I was simply expecting the search to behave differently. Now that I know what is going on it works fine.

And as a bonus there is now public record of my silly mistake :)

Note You need to log in before you can comment on or make changes to this bug.