Bug 1464321 - Failed to run atomic command
Failed to run atomic command
Status: CLOSED DUPLICATE of bug 1465336
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Colin Walters
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 01:45 EDT by Alex Jia
Modified: 2017-06-27 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 12:49:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2017-06-23 01:45:20 EDT
Description of problem:
Failed to run atomic command and sub-command and got error like this "ImportError: unknown dlopen() error" for rhel-atomic-vsphere-7.4.0-3.x86_64.vsphere.ova. 

Version-Release number of selected component (if applicable):

[root@atomic-host-test cloud-user]# cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.4


How reproducible:
always

Steps to Reproduce:
1. deploy rhel-atomic-vsphere-7.4.0-3.x86_64.vsphere.ova in vCenter and boot 
2. atomic


Actual results:
[root@atomic-host-test cloud-user]# atomic
Traceback (most recent call last):
  File "/usr/bin/atomic", line 24, in <module>
    import argparse
  File "/usr/lib64/python2.7/argparse.py", line 85, in <module>
    import collections as _collections
  File "/usr/lib64/python2.7/collections.py", line 8, in <module>
    from _collections import deque, defaultdict
ImportError: unknown dlopen() error


Expected results:


Additional info:

[root@atomic-host-test cloud-user]# pwd
/var/home/cloud-user

[root@atomic-host-test cloud-user]# ostree
Segmentation fault (core dumped)

[root@atomic-host-test cloud-user]# rpm
Segmentation fault (core dumped)
Comment 2 Jonathan Lebon 2017-06-27 11:23:23 EDT
This is most likely a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1462979, though I can't reproduce the segfaults on the qcow2 version. The next 7.4 compose shouldn't be too long and should fix the RHBZ above, so let's revisit then?

Note You need to log in before you can comment on or make changes to this bug.