Bug 1464353 - rear recovery ISO not working with secure boot
Summary: rear recovery ISO not working with secure boot
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear   
(Show other bugs)
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-23 08:13 UTC by Jagan
Modified: 2018-10-30 11:44 UTC (History)
6 users (show)

Fixed In Version: rear-2.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 11:43:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EFI shell screen shot with rescue ISO booting (32.69 KB, image/jpeg)
2017-06-23 08:13 UTC, Jagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3293 None None None 2018-10-30 11:44 UTC

Description Jagan 2017-06-23 08:13:46 UTC
Created attachment 1290929 [details]
EFI shell screen shot with rescue ISO booting

Description of problem:
When Secureboot enabled at BIOS level, Rear Rescue ISO is not booting to do the recovery.

Version-Release number of selected component (if applicable):
Rear1.17.2-9.el7_3.x86_64

How reproducible:
Create a rescue ISO using "rear mkrescue" comamnd, when secureboot enabled at BIOS level. try to boot with that ISO to do the recovery.

Steps to Reproduce:
1.rear mkrescue
2.boot with the rescue ISO


Actual results:
rescue ISO is not bootable.

Expected results:
rescue ISO should be bootable.

Additional info:

Comment 2 Jagan 2017-08-02 07:02:44 UTC
Any update on this Bugzilla ?

Comment 3 Pavel Cahyna 2017-11-13 16:54:25 UTC
I believe that secure boot is supported only in ReaR 2.2 and later. https://github.com/rear/rear/issues/1374

Comment 4 Jagan 2017-11-13 18:10:14 UTC
Hi Pavel Cahyna,

you are correct,ReaR 2.2 and later supports secure boot. 

In that case with RHEL 7.3 how we can use ReaR 2.2? with RHEL 7.3 distribution Rear1.17.2-9.el7_3.x86_64 is available. how we can get ReaR 2.2 with RHEL 7.3?

Thanks & Regards,
Jagan

Comment 5 Pavel Cahyna 2018-06-27 16:25:55 UTC
1464353 merged upstream in 2.2/c5ed9715f42a3ecbc14ba807ff74a01c1685fcb2

Comment 6 Pavel Cahyna 2018-06-29 18:11:47 UTC
(In reply to Jagan from comment #4)
> Hi Pavel Cahyna,
> 
> you are correct,ReaR 2.2 and later supports secure boot. 
> 
> In that case with RHEL 7.3 how we can use ReaR 2.2? with RHEL 7.3
> distribution Rear1.17.2-9.el7_3.x86_64 is available. how we can get ReaR 2.2
> with RHEL 7.3?
> 
> Thanks & Regards,
> Jagan

Hi jagan,

sorry for the late reply. We are considering updating ReaR to a newer version in the next RHEL 7 release, which should bring this functionality.

Comment 11 errata-xmlrpc 2018-10-30 11:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3293


Note You need to log in before you can comment on or make changes to this bug.