Bug 1464360 - Night Light doesn't work with xorg
Night Light doesn't work with xorg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Rui Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 04:57 EDT by Andrew Hutchings
Modified: 2017-09-05 02:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1488310 (view as bug list)
Environment:
Last Closed: 2017-07-12 18:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Hutchings 2017-06-23 04:57:52 EDT
Description of problem:
My hardware is a Lenovo x260 (Skylake i7 with Intel HD520 GPU)

Version-Release number of selected component (if applicable):
gnome-shell-3.24.2-1.fc26.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Log in using Gnome on xorg instead of wayland
2. Turn on night light
3. Wait until night light time has activated
4. See night light enabled icon but notice no change in screen colour

Actual results:
No change in screen colour on primary or secondary screens

Expected results:
Change in screen colour as observed in Wayland

Additional info:
Comment 1 Florian Müllner 2017-06-23 08:51:58 EDT
It's expected to work on X11 as well (and does here). In any case, gnome-shell only exposes the feature in the system menu, the actual functionality is implemented in gnome-settings-daemon's color plugin.
Comment 2 Andrew Stiegmann 2017-07-11 20:20:03 EDT
Works for me on Fedora 26 on XOrg.  Initially thought it was not functional but verified using manual mode.  Try that and see if that does the trick.
Comment 3 Andrew Hutchings 2017-07-12 03:55:58 EDT
Nope, not working in manual mode on the laptop's screen or external monitor.

My journal gets sprayed with this though when I try:

Jul 12 08:53:40 lxj-x260.local gsd-color[1803]: could not find device: property match 'XRANDR_name'='DP-1' does not exist
Jul 12 08:53:40 lxj-x260.local gsd-color[1803]: could not find device: property match 'XRANDR_name'='eDP-1' does not exist
Comment 4 Andrew Stiegmann 2017-07-12 17:44:17 EDT
Might be helpful if you upload the output of xrandr and the relevant journalctl entries to this bug.  Might be a clue in there as to what is happening.
Comment 5 Andrew Hutchings 2017-07-12 18:28:25 EDT
I started having tons of other Xrandr based issues including hangs and corruptions with multiple monitors recently too. This has been a F26 system since before the beta so must have picked up some bad config along the way, I've replaced the OS on it with something else as I needed it in production today. Not sure I'll get a chance to debug more soon. I don't have the problem on any of my other Fedora machines. I'll close as !bug. Sorry for wasting time.
Comment 6 Grant 2017-09-05 02:24:00 EDT
I also have problems with night light not working in Fedora 26 fully updated as of today.  Redshift is now broken also.  Redshift worked fine on this i7 laptop when running Fedora 25.  I am using multi monitor, but with single monitor attached, still getting problem.  Getting this error:
could not find device: property match 'XRANDR_name'='DP-1' does not exist

Note You need to log in before you can comment on or make changes to this bug.