Bug 1464369 - error: Multiple specifications found for remote "rhel-atomic-host-ostree"
error: Multiple specifications found for remote "rhel-atomic-host-ostree"
Status: CLOSED DUPLICATE of bug 1451410
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic (Show other bugs)
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Colin Walters
: Extras
Depends On:
  Show dependency treegraph
Reported: 2017-06-23 05:19 EDT by Alex Jia
Modified: 2017-06-23 09:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-06-23 09:02:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2017-06-23 05:19:25 EDT
Description of problem:
In version 7.4.0, we provide a local mirror of the repository under the /etc/ostree/remotes.d/, if users register system to Red Hat Subscription Management, and then users will have 3 ostree configurations, it will cause 'error: Multiple specifications found for remote "rhel-atomic-host-ostree"' when upgrading atomic host.

Version-Release number of selected component (if applicable):

[root@atomic-host-test-4109 cloud-user]# cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.4

[root@atomic-host-test-4109 cloud-user]# atomic host status
State: idle
● rhel-atomic-host:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-06-20 02:16:02)
                 Commit: c55bf46b4baaee58d637774e8515bc7e88b96e4acf099d8bca39c27757201442

How reproducible:

Steps to Reproduce:
1. deploy rhel-atomic-cloud-7.4.0-6.x86_64.qcow2 by libvirt/kvm and boot
2. register system to Red Hat Subscription Management
3. atomic host upgrade

Actual results:

[root@atomic-host-test-4109 cloud-user]# ls /etc/ostree/remotes.d/
redhat.conf  rhel-atomic-host.conf  rhel-atomic-host-ostree.conf

[root@atomic-host-test-4109 cloud-user]# atomic host upgrade
error: Multiple specifications found for remote "rhel-atomic-host-ostree"

Expected results:

Additional info:
Comment 2 Colin Walters 2017-06-23 09:02:22 EDT

*** This bug has been marked as a duplicate of bug 1451410 ***

Note You need to log in before you can comment on or make changes to this bug.