Bug 1464376 - Could not find a module for unknown on AH 7.4.0
Could not find a module for unknown on AH 7.4.0
Status: CLOSED DUPLICATE of bug 1462979
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 05:40 EDT by Gan Huang
Modified: 2017-09-06 16:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 10:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gan Huang 2017-06-23 05:40:32 EDT
Description of problem:
On AH 7.4.0, we can't query rpm packages by command "rpm -qa" on the host, this lead to installer failed when trying to install NTP mistakenly on AH.

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.121-1.git.0.ed0b72c.el7.noarch.rpm

# atomic host status
State: idle
Deployments:
● rhel-atomic-host:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-06-16 21:48:31)
                 Commit: 0b62181fb351d26ebb794438174c8dbc2ea5cc4c04c589b7be82e15695a2bbbb

`rpm -qa` returned nothing
# rpm -qa

How reproducible:
always

Steps to Reproduce:
1. Trigger installation against AH 7.4


Actual results:
Installer mistakenly checked that "openshift.clock.chrony_installed" was false due to command "rpm -q" is not useful any more on AH 7.4:
 
# rpm -q chrony
package chrony is not installed

Actually the service is installed.


Then installer tried to install NTP package on AH, but that's not available on AH. 

TASK [openshift_clock : Install ntp package] ***********************************
Friday 23 June 2017  08:45:48 +0000 (0:00:05.441)       0:12:25.215 *********** 
fatal: [openshift-133.lab.sjc.redhat.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find a module for unknown.

fatal: [openshift-151.lab.sjc.redhat.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find a module for unknown.

fatal: [openshift-124.lab.sjc.redhat.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find a module for unknown.

Expected results:
As Atomic Host is immutable, we don't have to check whether the *rpm* packages are installed or not. Should skip the rpm checks on AH.

Additional info:
Comment 2 Scott Dodson 2017-06-23 10:09:31 EDT

*** This bug has been marked as a duplicate of bug 1462979 ***
Comment 3 Shah Zobair 2017-09-06 15:50:32 EDT
(In reply to Scott Dodson from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 1462979 ***

Not sure how this bug is duplicate of bug 1462979 because that is RHEL rpm specific. We are getting the same error while installing OpenShift 3.6 on RHEL Atomic, is there any workaround for this?



TASK [openshift_clock : Set clock facts] ***************************************
changed: [lnyce095xsdi008.sdi.corp.example.com]

TASK [openshift_clock : Install ntp package] ***********************************
fatal: [lnyce095xsdi008.sdi.corp.example.com]: FAILED! => {
    "changed": false,
    "failed": true
}

MSG:

Could not find a module for unknown.


NO MORE HOSTS LEFT *************************************************************
        to retry, use: --limit @/root/openshift/infra-maint/roles/pre_upgrade/ose-3.6/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-master/scaleup.retry
Comment 4 Scott Dodson 2017-09-06 16:09:18 EDT
Shah,

Which commit of atomic host are you at? `atomic host status` please. The only way that task would've executed is if chrony weren't installed and I've just looked at 7.4.0 GA and 7.4.1 both have chrony.

7.4.0 = 846fb0e18e65bd9a62fc9d952627413c6467c33c2d726449a1d7ad7690bbb93a
7.4.1 = e83c16780259c5272684221e2a6007300d94bbfdc5432f9ab6025300f447145b
Comment 5 Shah Zobair 2017-09-06 16:30:56 EDT
(In reply to Scott Dodson from comment #4)
> Shah,
> 
> Which commit of atomic host are you at? `atomic host status` please. The
> only way that task would've executed is if chrony weren't installed and I've
> just looked at 7.4.0 GA and 7.4.1 both have chrony.
> 
> 7.4.0 = 846fb0e18e65bd9a62fc9d952627413c6467c33c2d726449a1d7ad7690bbb93a
> 7.4.1 = e83c16780259c5272684221e2a6007300d94bbfdc5432f9ab6025300f447145b

I think I have to update the AH:

-bash-4.2# atomic host status
State: idle
Deployments:
● bac-atomic-host:rhel-atomic-host/7/x86_64/standard
       Version: 7.3.3 (2017-02-27 16:31:38)
        Commit: bfc591ba1a4395c6b8e54d34964b05df4a61e0d82d20cc1a2fd817855c7e2da5
        OSName: rhel-atomic-host

  rhel-atomic-host:rhel-atomic-host/7/x86_64/standard
       Version: 7.3.2 (2017-01-13 22:00:41)
        Commit: 96826a0d917d7ff10f9fd0289581649f2ffbddd76f3b80efd3d95cc11915cacb
        OSName: rhel-atomic-host
Comment 6 Scott Dodson 2017-09-06 16:46:32 EDT
Is your RPMDB corrupt? what do you get from `rpm -q chrony` ?

Our QE teams would've tested 7.3.3 at some point in the past and this is a pretty obvious failure that I'm sure they would've encountered if RHEL AH 7.3.3 lacked chrony, in fact this bug was opened by our QE team who ran into such a problem in an early 7.4.0 build.
Comment 7 Shah Zobair 2017-09-06 16:48:38 EDT
You are right, chrony is not installed. We are trying to upgrade the host 7.4.1

-bash-4.2# rpm -q chrony
package chrony is not installed

Thanks for the notes and help.

Note You need to log in before you can comment on or make changes to this bug.