Bug 1464384 - Should not display default ebs storageclass name when oc get pvc of provisioners-efs
Should not display default ebs storageclass name when oc get pvc of provision...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low
: ---
: 3.7.0
Assigned To: Matthew Wong
chaoyang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 05:58 EDT by chaoyang
Modified: 2018-04-05 05:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-05 05:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 05:29 EDT

  None (edit)
Description chaoyang 2017-06-23 05:58:43 EDT
Description of problem:
Should not display default ebs storageclass when oc get pvc of efs external provisioner

Version-Release number of selected component (if applicable):
oc v3.6.121
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:
Always
Steps to Reproduce:
1.Prepare OCP instance, record  master host name
2.Run the openshift ansible to install external provisoner 
ansible-playbook -v -i aws playbooks/common/openshift-cluster/openshift_provisioners.yml \
   -e openshift_provisioners_install_provisioners=True \
    -e openshift_provisioners_efs=True \
    -e openshift_provisioners_efs_fsid=xx \
    -e openshift_provisioners_efs_region=us-east-1 \
    -e openshift_provisioners_efs_aws_access_key_id=xx \
    -e openshift_provisioners_efs_aws_secret_access_key=xx \
    -e openshift_provisioners_efs_path=/data/persistentvolumes\
    -e openshift_provisioners_image_prefix=registry.ops.openshift.com/openshift3/
3.oc get pvc
[root@ip-172-18-11-245 ~]# oc get pvc
NAME               STATUS    VOLUME             CAPACITY   ACCESSMODES   STORAGECLASS   AGE
provisioners-efs   Bound     provisioners-efs   1Mi        RWX           gp2            1h
[root@ip-172-18-11-245 ~]# oc get pvc provisioners-efs -o yaml
apiVersion: v1
kind: PersistentVolumeClaim
metadata:
  annotations:
    kubectl.kubernetes.io/last-applied-configuration: |
      {"apiVersion":"v1","kind":"PersistentVolumeClaim","metadata":{"annotations":{},"name":"provisioners-efs","namespace":"openshift-infra"},"spec":{"accessModes":["ReadWriteMany"],"resources":{"requests":{"storage":"1Mi"}},"selector":{"matchLabels":{"provisioners-efs":"efs"}}}}
    pv.kubernetes.io/bind-completed: "yes"
    pv.kubernetes.io/bound-by-controller: "yes"
  creationTimestamp: 2017-06-22T06:20:20Z
  name: provisioners-efs
  namespace: openshift-infra
  resourceVersion: "7016"
  selfLink: /api/v1/namespaces/openshift-infra/persistentvolumeclaims/provisioners-efs
  uid: de1f986c-5712-11e7-b67a-0ee146755e36
spec:
  accessModes:
  - ReadWriteMany
  resources:
    requests:
      storage: 1Mi
  selector:
    matchLabels:
      provisioners-efs: efs
  storageClassName: gp2
  volumeName: provisioners-efs
status:
  accessModes:
  - ReadWriteMany
  capacity:
    storage: 1Mi
  phase: Bound


oc get pv
[root@ip-172-18-11-245 ~]# oc get pv
NAME               CAPACITY   ACCESSMODES   RECLAIMPOLICY   STATUS    CLAIM                              STORAGECLASS   REASON    AGE
provisioners-efs   1Mi        RWX           Retain          Bound     openshift-infra/provisioners-efs                            1h
[root@ip-172-18-11-245 ~]# oc get pv provisioners-efs -o yaml
apiVersion: v1
kind: PersistentVolume
metadata:
  annotations:
    kubectl.kubernetes.io/last-applied-configuration: |
      {"apiVersion":"v1","kind":"PersistentVolume","metadata":{"annotations":{},"labels":{"provisioners-efs":"efs"},"name":"provisioners-efs","namespace":""},"spec":{"accessModes":["ReadWriteMany"],"capacity":{"storage":"1Mi"},"claimRef":{"name":"provisioners-efs","namespace":"openshift-infra"},"nfs":{"path":"/data/persistentvolumes","server":"fs-c8e05981.efs.us-east-1.amazonaws.com"}}}
  creationTimestamp: 2017-06-22T06:20:03Z
  labels:
    provisioners-efs: efs
  name: provisioners-efs
  resourceVersion: "8678"
  selfLink: /api/v1/persistentvolumes/provisioners-efs
  uid: d3c966a4-5712-11e7-b67a-0ee146755e36
spec:
  accessModes:
  - ReadWriteMany
  capacity:
    storage: 1Mi
  claimRef:
    apiVersion: v1
    kind: PersistentVolumeClaim
    name: provisioners-efs
    namespace: openshift-infra
    resourceVersion: "7012"
    uid: de1f986c-5712-11e7-b67a-0ee146755e36
  nfs:
    path: /
    server: fs-c8e05981.efs.us-east-1.amazonaws.com
  persistentVolumeReclaimPolicy: Retain
status:
  phase: Bound
Actual results:
When check pvc , there is storageclass name is default ebs storageclass name gp2


Expected results:
Should not display default storageclass name gp2

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
Comment 1 Matthew Wong 2017-06-23 11:03:05 EDT
Thanks, pr submitted https://github.com/openshift/openshift-ansible/pull/4571
Comment 3 chaoyang 2018-01-25 01:24:29 EST
This is passed.
[root@ip-172-18-5-98 ~]# oc get pvc
NAME               STATUS    VOLUME             CAPACITY   ACCESS MODES   STORAGECLASS   AGE
provisioners-efs   Bound     provisioners-efs   1Mi        RWX                           5m
Comment 7 errata-xmlrpc 2018-04-05 05:28:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636

Note You need to log in before you can comment on or make changes to this bug.