Bug 1464389 - /usr/lib64/perl5/CORE/perl.h requires <xlocale.h> which does not exist
/usr/lib64/perl5/CORE/perl.h requires <xlocale.h> which does not exist
Status: CLOSED DUPLICATE of bug 1464244
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2017-06-23 06:04 EDT by Richard W.M. Jones
Modified: 2017-06-23 06:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 06:19:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (1.91 MB, text/plain)
2017-06-23 06:05 EDT, Richard W.M. Jones
no flags Details
root.log (216.61 KB, text/plain)
2017-06-23 06:06 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2017-06-23 06:04:59 EDT
Description of problem:

/usr/lib64/perl5/CORE/perl.h:738:13: fatal error: xlocale.h: No such file or directory
 #   include <xlocale.h>
             ^~~~~~~~~~~

Version-Release number of selected component (if applicable):

glibc-2.25.90-12.fc27
perl-devel-4:5.26.0-393.fc27

How reproducible:

Unknown.

Steps to Reproduce:
1. Build an XS file in Rawhide.

https://koji.fedoraproject.org/koji/taskinfo?taskID=20114709

Full build.log, root.log attached.
Comment 1 Richard W.M. Jones 2017-06-23 06:05 EDT
Created attachment 1290961 [details]
build.log
Comment 2 Richard W.M. Jones 2017-06-23 06:06 EDT
Created attachment 1290962 [details]
root.log
Comment 3 Richard W.M. Jones 2017-06-23 06:10:51 EDT
From the glibc changelog:

* Wed Jun 21 2017 Florian Weimer <fweimer@redhat.com> - 2.25.90-8
- Adjust build requirements for gcc, binutils, kernel-headers.
- Auto-sync with upstream master,
  commit 43e0ac24c836eed627a75ca932eb7e64698407c6, changing:
- Remove <xlocale.h>

So I guess either Perl needs to be recompiled or else glibc is
broken.  No reason is given for dropping xlocale.h.
Comment 4 Richard W.M. Jones 2017-06-23 06:19:01 EDT

*** This bug has been marked as a duplicate of bug 1464244 ***

Note You need to log in before you can comment on or make changes to this bug.