Bug 1464392 - Hosted engine upgrade fails if appliance is not available before the installation.
Hosted engine upgrade fails if appliance is not available before the installa...
Status: CLOSED DUPLICATE of bug 1458655
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
4.0.7
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Simone Tiraboschi
meital avital
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 06:39 EDT by Roman Hodain
Modified: 2017-07-31 05:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 05:33:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport fromthe hosted engine node (12.11 MB, application/x-xz)
2017-06-23 06:42 EDT, Roman Hodain
no flags Details

  None (edit)
Description Roman Hodain 2017-06-23 06:39:19 EDT
Description of problem:
When upgrade din hosted engine from RHEV 3.6 to RHV 4.0 the hosted-engine --upgrade-appliance installs two appliances. One for 4.0 and one for 4.1 which fails becuase of a conflickt.

Version-Release number of selected component (if applicable):
RHV 4.0

How reproducible:
100%

Steps to Reproduce:
1. Proceed with hosted-engine --upgrade-appliance without installing the appliance in advance

Actual results:
# hosted-engine --upgrade-appliance
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
         
          ==================================================================================
          Welcome to the oVirt Self Hosted Engine setup/Upgrade tool.
         
          Please refer to the oVirt install guide:
          https://www.ovirt.org/documentation/how-to/hosted-engine/#fresh-install
          Please refer to the oVirt upgrade guide:
          https://www.ovirt.org/documentation/how-to/hosted-engine/#upgrade-hosted-engine
          ==================================================================================
          Continuing will upgrade the engine VM running on this hosts deploying and configuring a new appliance.
          If your engine VM is already based on el7 you can also simply upgrade the engine there.
          This procedure will create a new disk on the hosted-engine storage domain and it will backup there the content of your current engine VM disk.
          The new el7 based appliance will be deployed over the existing disk destroying its content; at any time you will be able to rollback using the content of the backup disk.
          You will be asked to take a backup of the running engine and copy it to this host.
          The engine backup will be automatically injected and recovered on the new appliance.
          Are you sure you want to continue? (Yes, No)[Yes]: 
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20170623123040-8sabrb.log
          Version: otopi-1.6.2 (otopi-1.6.2-1.el7ev)
[ INFO  ] Detecting available oVirt engine appliances
[ ERROR ] No engine appliance image is available on your system.
          The oVirt engine appliance is now required to deploy hosted-engine.
          You could get oVirt engine appliance installing ovirt-engine-appliance rpm.
          Do you want to install ovirt-engine-appliance rpm? (Yes, No) [Yes]: 
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Installing the oVirt engine appliance
[ INFO  ] Yum Status: Downloading Packages
[ INFO  ] Yum Download/Verify: 1:rhevm-appliance-4.0.20170307.0-1.el7ev.noarch
[ INFO  ] Yum Download/Verify: 1:rhvm-appliance-4.1.20170619.0-1.el7.noarch
[ INFO  ] Yum Status: Check Package Signatures
[ INFO  ] Yum Status: Running Test Transaction
[ ERROR ] Yum Test Transaction Errors:   file /etc/ovirt-hosted-engine/10-appliance.conf conflicts between attempted installs of rhvm-appliance-1:4.1.20170619.0-1.el7.noarch and rhevm-appliance-1:4.0.20170307.0-1.el7ev.noarch 
[ ERROR ] Failed to execute stage 'Environment packages setup': Test Transaction Errors:   file /etc/ovirt-hosted-engine/10-appliance.conf conflicts between attempted installs of rhvm-appliance-1:4.1.20170619.0-1.el7.noarch and rhevm-appliance-1:4.0.20170307.0-1.el7ev.noarch 
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine upgrade failed
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20170623123040-8sabrb.log


Expected results:
Correct appliance is downloaded
Comment 1 Roman Hodain 2017-06-23 06:42 EDT
Created attachment 1290967 [details]
sosreport fromthe hosted engine node

# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id                                             repo name                                                        status
!rhel-7-server-rh-common-rpms/7Server/x86_64        Red Hat Enterprise Linux 7 Server - RH Common (RPMs)                228
!rhel-7-server-rhev-mgmt-agent-rpms/7Server/x86_64  Red Hat Enterprise Virtualization Management Agents for RHEL 7 (    709
!rhel-7-server-rhv-4-mgmt-agent-rpms/7Server/x86_64 Red Hat Virtualization 4 Management Agents for RHEL 7 (RPMs)        467
!rhel-7-server-rpms/7Server/x86_64                  Red Hat Enterprise Linux 7 Server (RPMs)                         14,474
repolist: 15,878
Comment 2 Sandro Bonazzola 2017-06-23 07:24:01 EDT
Looks like a duplicate of bug #1458655.
Please reopen if I'm wrong.

*** This bug has been marked as a duplicate of bug 1458655 ***
Comment 3 Roman Hodain 2017-07-03 08:52:04 EDT
(In reply to Sandro Bonazzola from comment #2)
> Looks like a duplicate of bug #1458655.
> Please reopen if I'm wrong.
> 
> *** This bug has been marked as a duplicate of bug 1458655 ***

I am not entirely sure if the bug #1458655 fixes the problem. From the doc text:

"
When ovirt-hosted-engine-setup searches for the appliance, it finds both rhevm-appliance and rhvm-appliance. Previously, while trying get the latest appliance version from ovirt-hosted-engine-setup, otopi built a transaction that installed rhevm-appliance and then upgraded it to rhvm-appliance, doubling the download size. This has now been fixed so that only rhvm-appliance is installed.
"

I understand that the ovirt-hosted-engine-setup will install the RHV appliance instead of RHEV appliance. That is a problem as the flow 3.6 -> 4.x require appliance for 4.0. We cannot directly upgrade to 4.1.

Yes this can be workarounded by manually installing the rhevm appliance, but if it is not installed yet then the installation will fail in current version and will directly upgrade to 4.1 when 4.1.3 is released. Do U understand it correctly?
Comment 4 Sandro Bonazzola 2017-07-17 05:14:03 EDT
Simone, can you check comment #3?
Comment 5 Simone Tiraboschi 2017-07-31 05:33:54 EDT
(In reply to Roman Hodain from comment #3)
> I understand that the ovirt-hosted-engine-setup will install the RHV
> appliance instead of RHEV appliance. That is a problem as the flow 3.6 ->
> 4.x require appliance for 4.0. We cannot directly upgrade to 4.1.

After the fix for #1458655, hosted-engine-setup will install rhevm-appliance (4.0!) on upgrades and rhvm-appliance (4.1!) on fresh installs.

Please reopen 1458655 if it doesn't behaves as described here.

*** This bug has been marked as a duplicate of bug 1458655 ***

Note You need to log in before you can comment on or make changes to this bug.