This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1464408 - gluster-block: cli output looks weird, merging multiple lines without any spaces
gluster-block: cli output looks weird, merging multiple lines without any spaces
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Prasanna Kumar Kalever
Sweta Anandpara
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-23 07:26 EDT by Prasanna Kumar Kalever
Modified: 2017-09-21 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: gluster-block-0.2.1-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:20:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2017-06-23 07:26:21 EDT
Description of problem:
Fix missing newline characters in cli prints

Ex:

$ gluster-block create sample
argument '<volname/blockname>'(sample) is incorrectgluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]

$ gluster-block create ?l0.
argument '<volname/blockname>'(?l0.) is incorrectgluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]


Ideally they should look like:
$ gluster-block create sample
argument '<volname/blockname>'(sample) is incorrect
gluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]

$ gluster-block create ?l0.
argument '<volname/blockname>'(?l0.) is incorrect
gluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]
Comment 6 Sweta Anandpara 2017-06-29 04:20:15 EDT
Tested and verified this on the build glusterfs-3.8.4-31 and gluster-block-0.2.1-3.

The error messages, and the help content of gluster-block is syntactically fine now. Moving this BZ to verified in 3.3. Logs are pasted below:

[root@dhcp47-115 ~]# gluster-block create
Inadequate arguments for create:
gluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]
[root@dhcp47-115 ~]# gluster-block create testvol
argument '<volname/blockname>'(testvol) is incorrect
gluster-block create <volname/blockname> [ha <count>] [auth enable|disable] <HOST1[,HOST2,...]> <size> [--json*]
[root@dhcp47-115 ~]# gluster-block help
gluster-block (0.2.1)
usage:
  gluster-block <command> <volname[/blockname]> [<args>] [--json*]

commands:
  create  <volname/blockname> [ha <count>]
                              [auth <enable|disable>]
                              [prealloc <full|no>]
                              <host1[,host2,...]> <size>
        create block device [defaults: ha 1, auth disable, prealloc no]

  list    <volname>
        list available block devices.

  info    <volname/blockname>
        details about block device.

  delete  <volname/blockname>
        delete block device.

  modify  <volname/blockname> <auth enable|disable>
        modify block device.

  help
        show this message and exit.

  version
        show version info and exit.

supported JSON formats:
  --json|--json-plain|--json-spaced|--json-pretty
[root@dhcp47-115 ~]# gluster-block info testvol
argument '<volname/blockname>'(testvol) is incorrect
gluster-block info <volname/blockname> [--json*]
[root@dhcp47-115 ~]# gluster-block modify testvol/testblock
Inadequate arguments for modify:
gluster-block modify <volname/blockname> <auth enable|disable> [--json*]
[root@dhcp47-115 ~]# 
[root@dhcp47-115 ~]# rpm -qa | grep gluster
glusterfs-cli-3.8.4-31.el7rhgs.x86_64
libvirt-daemon-driver-storage-gluster-3.2.0-10.el7.x86_64
glusterfs-libs-3.8.4-31.el7rhgs.x86_64
glusterfs-events-3.8.4-31.el7rhgs.x86_64
vdsm-gluster-4.17.33-1.1.el7rhgs.noarch
gluster-block-0.2.1-3.el7rhgs.x86_64
glusterfs-api-3.8.4-31.el7rhgs.x86_64
python-gluster-3.8.4-31.el7rhgs.noarch
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
gluster-nagios-addons-0.2.9-1.el7rhgs.x86_64
samba-vfs-glusterfs-4.6.3-3.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-31.el7rhgs.x86_64
glusterfs-server-3.8.4-31.el7rhgs.x86_64
glusterfs-rdma-3.8.4-31.el7rhgs.x86_64
glusterfs-debuginfo-3.8.4-26.el7rhgs.x86_64
glusterfs-3.8.4-31.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-31.el7rhgs.x86_64
glusterfs-fuse-3.8.4-31.el7rhgs.x86_64
[root@dhcp47-115 ~]#
Comment 8 errata-xmlrpc 2017-09-21 00:20:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773

Note You need to log in before you can comment on or make changes to this bug.