Bug 146447 - dlamc1 never returns
Summary: dlamc1 never returns
Status: CLOSED DUPLICATE of bug 138447
Alias: None
Product: Fedora
Classification: Fedora
Component: lapack   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL: http://www.theochem.kth.se/~pawsa/dla...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-28 11:24 UTC by Pawel Salek
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pawel Salek 2005-01-28 11:24:26 UTC
Description of problem:
All calls made to dlamc1 subroutine of lapack never return. Try the
following test program:
      PROGRAM aaa
      INTEGER BETA, T
      LOGICAL RND, IEEE1
      CALL DLAMC1( BETA, T, RND, IEEE1 )
      END
This behavior is compiler dependent and does not occur when the
library is compiled with lower optimization options. I cannot tell
whether it is a compiler bug (I tested with native
gcc-g77-3.4.2-6.fc3) or actually a bug in algorithm: it seems to do
pretty ugly things and - I think - rely on IEEE arithmetics. Older gcc
 versions (eg. gcc-g77-3.3.3-7) do not expose the bug.


Version-Release number of selected component (if applicable):
lapack-3.0-25

How reproducible:
Always

Steps to Reproduce:
1. Compile test program with "g77 test.f -llapack -lblas" and run it
    

Actual Results:  Program will never stop.

Expected Results:  Program should return instantenously.

Additional info:

Recompiling the routine with current g77 and only -O option makes the
problem dissappear.

Comment 1 Pawel Salek 2005-01-28 11:30:57 UTC
I seem to be unable to attach a file to the report. Anyway, the URL
locates a file that contains relevant subroutines from lapack and
servers as a test case. Compiling it with -O give a code that works as
expected. Code compiled with -O2 will never stop.

Comment 2 Ivana Varekova 2005-01-28 12:05:12 UTC

*** This bug has been marked as a duplicate of 138447 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:08:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.