Bug 1464493 - gluster-block: remove iscsid.service from systemd unit and add rpcbind as dependency in spec
gluster-block: remove iscsid.service from systemd unit and add rpcbind as dep...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Prasanna Kumar Kalever
Sweta Anandpara
3.3.0-devel-freeze-exception
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-23 10:45 EDT by Prasanna Kumar Kalever
Modified: 2017-09-21 00:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: gluster-block-0.2.1-3.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:20:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2773 normal SHIPPED_LIVE new packages: gluster-block 2017-09-21 04:16:22 EDT

  None (edit)
Description Prasanna Kumar Kalever 2017-06-23 10:45:24 EDT
Description of problem:
${SUBJECT}

iscsid is required by initiator only. Hence we don't need it in the gluster-blockd.service


Problem with keeping that for now,
1. We need to endup installing iscsi-initiator-utils extra
2. as we did not made iscsi-initiator-utils as a dependent in our gluster-block spec, people notice gluster-blockd doesn't start due to missing dependency iscsid.
Comment 10 errata-xmlrpc 2017-09-21 00:20:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773

Note You need to log in before you can comment on or make changes to this bug.