Bug 14645 - Warning message from checkpc
Summary: Warning message from checkpc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-25 23:36 UTC by Olivier Baudron
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 23:36:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2000-07-25 23:36:50 UTC
At boot time, lpd outputs warning message:

Starting lpd: Warning - owner/group of '/var/run/lpd.printer' are 0/7, not
4/7
Warning -   changing ownership '/var/run/lpd.printer' to 4/7
Warning -   changing ownership '/var/run/lpd.printer' to 4/7

This is because, in /etc/rc.d/init.d/lpd, 'checkpc -f' does not find the
file /var/run/lpd.printer. So it creates one but with wrong permission.

Comment 1 Nalin Dahyabhai 2000-07-26 19:24:24 UTC
It's a bogus error message -- checkpc complains that the lock file is
not writable even when it doesn't exist.  Fixed in LPRng-3.6.21-8,
appearing soon in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.