Bug 1464537 - Image pull error from registry.access.redhat.com (3.5)
Image pull error from registry.access.redhat.com (3.5)
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5.z
Assigned To: Cesar Wong
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 13:30 EDT by Cesar Wong
Modified: 2017-07-11 06:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When doing an incremental build, the s2i builder pulls its builder image before calling the save-artifacts script and doesn't ensure that the builder image is still there when it calls assemble. Consequence: This leaves a gap of time between the start of the build and the calling of the assemble script in which the image can be removed. If the image is removed, the build fails. Fix: Add a call to ensure that the builder image exists right before calling the assemble script. Result: The chance of the assemble script running and not finding an available builder image is greatly reduced.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 06:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cesar Wong 2017-06-23 13:30:58 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1446925
Targeting v3.5 branch

Description of problem:

On various occasions the builds fail because the image is reported as not available in the registry but pulling manually from CMD does work. 


Version-Release number of selected component (if applicable):
3.4.1.7

How reproducible:
Intermittently

Steps to Reproduce:
1.
2.
3.

Actual results:
- First fail to inspect the image:
I0427 12:38:46.688268       1 docker.go:524] error inspecting image registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349971b43a2c839df255317d2cbef0c2f7cfa86e449b323afe69c28b: Error: No such image: registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349971b43a2c839df255317d2cbef0c2f7cfa86e449b323afe69c28b

- Then it can't not find it locally:
I0427 12:38:46.688338       1 docker.go:511] Image "registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349..." not available locally, pulling ...

- Then it use the image locally:
I0427 12:38:49.294607       1 docker.go:515] Using locally available image "registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349..."
I0427 12:38:49.302982       1 docker.go:515] Using locally available image "registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349..."

- But finally fails when trying to get the metadata:
I0427 12:41:30.502064 1 docker.go:899] error: Unable to get image metadata for registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349971b43a2c839df255317d2cbef0c2f7cfa86e449b323afe69c28b: Error: No such image: registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:b82967f5349971b43a2c839df255317d2cbef0c2f7cfa86e449b323afe69c28b
 

Expected results:
Image pulled successful

Additional info:
The same images can be manually pulled with docker pull everytime.
Comment 3 wewang 2017-06-30 01:33:47 EDT
verified in 
openshift v3.5.5.31
kubernetes v1.5.2+43a9be4
etcd 3.1.0

steps:
1.  $oc new-app openshift/jboss-webserver30-tomcat8-openshift~https://github.com/jboss-openshift/openshift-quickstarts.git#1.1 --context-dir=tomcat-websocket-chat
2.  $oc get builds
NAME                      TYPE      FROM          STATUS     STARTED                  DURATION
openshift-quickstarts-1   Source    Git@292cc9a   Complete   Less than a second ago   2m8s
3.$ oc describe build openshift-quickstarts-1
Name:		openshift-quickstarts-1
Namespace:	wewang
Created:	Less than a second ago
Labels:		app=openshift-quickstarts
		buildconfig=openshift-quickstarts
		openshift.io/build-config.name=openshift-quickstarts
		openshift.io/build.start-policy=Serial
Annotations:	openshift.io/build-config.name=openshift-quickstarts
		openshift.io/build.number=1
		openshift.io/build.pod-name=openshift-quickstarts-1-build

Status:		Complete
Started:	Fri, 30 Jun 2017 13:30:14 CST
Duration:	2m8s

Build Config:	openshift-quickstarts
Build Pod:	openshift-quickstarts-1-build
Image Digest:	sha256:5e7ccb53d31ffd1e6802a42a7d0df669cc79118d2fad18b053031bcd11264d2b

Strategy:		Source
URL:			https://github.com/jboss-openshift/openshift-quickstarts.git
Ref:			1.1
ContextDir:		tomcat-websocket-chat
Commit:			292cc9a (helloworld-mdb quickstart: CLOUD-199)
Author/Committer:	Kevin Conner
From Image:		DockerImage registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift@sha256:c347a9e7286e3c750ce4d43cf931ef8deadfb8c81e330b69cb7b0d88b0d49643
Output to:		ImageStreamTag openshift-quickstarts:latest
Comment 4 wewang 2017-07-02 22:30:25 EDT
yes, it's better to have docs
Comment 6 errata-xmlrpc 2017-07-11 06:47:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Note You need to log in before you can comment on or make changes to this bug.