Bug 1464578 - [RFE] Content View Filter Preview [NEEDINFO]
[RFE] Content View Filter Preview
Status: CLOSED DUPLICATE of bug 1148490
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.10
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 15:34 EDT by Paul Armstrong
Modified: 2017-07-04 18:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-04 18:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bkearney: needinfo? (mmccune)


Attachments (Terms of Use)

  None (edit)
Description Paul Armstrong 2017-06-23 15:34:35 EDT
Description of problem: When creating filters for content views it is sometimes difficult to envision the results that multiple filters will have when implemented together on a given content view. If you use trial by error and have hosts that are subscribed to content views in Library, this can result in a lot of movement. Most of this is handled by the current logic in 6.2.10 asking you to move hosts to environments lifecycle environments where the content is not in use, move activation keys, etc.. It currently doesn't fix Host Groups though...

So... we know that subscribing systems to CVs in Library is bad. Either we prevent this and make sure that there is at least one environment in one path above Library and prevent the subscription of hosts to Library - now publishing to Library gives the preview. Or, implement a preview that just runs a query on the content using the filter logic and show the user the output for review.

Version-Release number of selected component (if applicable):
6.2.10

How reproducible:
Always

Steps to Reproduce:
1. Feature does not exist
2.
3.

Actual results:
Doesn't exist

Expected results:
Provides a method to preview filter results on content prior to publishing to an active environment with hosts in it.


Additional info:
Many ways to fry this fish...
Comment 3 Brad Buckingham 2017-07-04 18:30:21 EDT
This bug appears to be a duplicate of bug 1148490; therefore, closing.  If there are any concerns, please re-open and provide additional details.  Thanks for the request!

*** This bug has been marked as a duplicate of bug 1148490 ***

Note You need to log in before you can comment on or make changes to this bug.