Bug 1464580 - SmartState Analysis Fails for RHEL VM based on Swift image
SmartState Analysis Fails for RHEL VM based on Swift image
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.8.0
All All
high Severity high
: GA
: cfme-future
Assigned To: Rich Oliveri
Satyajit Bulage
smartstate
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 15:37 EDT by Ryan Spagnola
Modified: 2018-02-27 13:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-27 13:56:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Ryan Spagnola 2017-06-23 15:37:20 EDT
Description of problem:
When performing a SmartState Analysis on a RHEL 7 VM the task is failing due to not being able to find the root disk.

This issue only occurs on VMs and Templates based on SWIFT's RHEL image.

The SWIFT image has /usr as a mount point and it is mounted read-only when the VM is running.

Version-Release number of selected component (if applicable):
5.8

How reproducible:
Consistantly

Steps to Reproduce:
1. Run SSA on Swift rhel image
2.
3.

Actual results:
SSA fails

Expected results:
SSA success

Additional info:
Running SmartState on RHEL based VMs when that do not use the SWIFT image is successful. For example a VM was created based of the CloudForms template and a SmartState Analysis was successful. SmartState Analysis is also successful on the SWIFT image for Windows.

I think the failure may have to do with the fact that the SWIFT image has /usr as a mount point instead of a simple directory on the / filesystem.
Comment 9 Mo Morsi 2017-07-25 21:42:57 EDT
There is a potential difference between the disk to be mounted at /usr residing in the "VMDK Disk" (as Brant mentioned) and the disk being "on VMware Infra" (Ryan). Which is the case?

Also any additional information may help to debug. What FS resides on /usr? Would it be possible to get a copy of the disk and/or failed logs?
Comment 25 Mo Morsi 2017-08-07 15:07:00 EDT
Any update from the customer as far as the disk / environment where the issue resides?
Comment 27 Mo Morsi 2017-09-01 17:24:56 EDT
Hey Ryan any update?

Thanks,
  -Mo
Comment 29 Mo Morsi 2017-09-26 15:38:49 EDT
Alight, until an environment where the issue can reproduced can be provided I suggest closing this as "CANTFIX" for the time being
Comment 34 Mo Morsi 2017-11-07 10:44:22 EST
Hey Ryan, Yoder, I confirmed we do not currently support scanning of md raid volumes. Reassigning this RFE back to the original owner.

Note You need to log in before you can comment on or make changes to this bug.