Bug 14646 - pam_console emits debugging messages when debugging is not turned on
Summary: pam_console emits debugging messages when debugging is not turned on
Status: CLOSED DUPLICATE of bug 14644
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-25 23:40 UTC by Chris Siebenmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-26 19:20:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make the debugging messages actually debugging messages (703 bytes, patch)
2000-07-25 23:41 UTC, Chris Siebenmann
no flags Details | Diff

Description Chris Siebenmann 2000-07-25 23:40:53 UTC
The new pam_console RPM emits debugging messages, messages about
perfectly normal and expected conditions, when the 'debug' argument
has not been specified to pam_console. The two immediately noticeable
(and annoying) messages are:
	console %s is owned by UID 0
and	console %s is a character device
These messages mean nothing more than that everything is OK. As such
they should only be emitted when debugging is turned on. Worse yet,
the code attempts to send them out at priority LOG_ERR, which should
be saved for things that indicate, well, important errors.

 I will attach a simple patch to fix this.

Comment 1 Chris Siebenmann 2000-07-25 23:41:25 UTC
Created attachment 1553 [details]
make the debugging messages actually debugging messages

Comment 2 Nalin Dahyabhai 2000-07-26 19:20:59 UTC

*** This bug has been marked as a duplicate of 14644 ***


Note You need to log in before you can comment on or make changes to this bug.