Bug 146463 - [mis-compilation] org.eclipse.ui.forms_3.1.0.jar: manifest editor, Build tab does not show up
[mis-compilation] org.eclipse.ui.forms_3.1.0.jar: manifest editor, Build tab ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks: 159880
  Show dependency treegraph
 
Reported: 2005-01-28 10:55 EST by Aaron Luchko
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-08 15:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log (6.98 KB, text/plain)
2005-01-28 11:58 EST, Aaron Luchko
no flags Details

  None (edit)
Description Aaron Luchko 2005-01-28 10:55:14 EST
Description of problem:
In a feature plugin if you open the feature.xml editor and click on
the build tab the screen never redraws in the area of the build tab.
Comment 1 Aaron Luchko 2005-01-28 11:49:34 EST
This doesn't seem to be confined to a single tab, next time build was
somewhat fine and overview wasn't refreshing.  The plugin.xml editor
also had problems, closing and reopening the editor the same tabs had
the same problems
Comment 2 Aaron Luchko 2005-01-28 11:58:14 EST
Created attachment 110361 [details]
error log

Stack trace that was generated when I tried to open the plugin.xml after
closing (I'm assuming it's related...)
Comment 3 Ben Konrath 2005-04-04 13:39:44 EDT
Hi Aaron, Can you confirm that this problem still happens with the latest rpms:

eclipse-platform-3.1.0_fc-0.M5.16
gcc-java-4.0.0-0.39

Thanks.
Comment 4 Andrew Overholt 2005-04-20 16:55:39 EDT
Aaron, does this still happen with the new 3.1M6 builds?
Comment 5 Aaron Luchko 2005-05-03 16:44:32 EDT
Yes it still occurs.  With any of the xml editors (plugin.xml, fragment.xml,
feature.xml) the build tab never refreshes.
Comment 6 Andrew Overholt 2005-05-04 10:00:06 EDT
This looks like it could be another manifestation of bug 151919.
Comment 7 Ben Konrath 2005-05-04 13:30:04 EDT
Aaron, can you post another stack trace from the new RPM version and specify the
version numbers? Thanks, Ben
Comment 8 Aaron Luchko 2005-05-04 14:16:41 EDT
Unfortunately this isn't generating any kind of log file (the original one must
of been unrelated). The version is 3.1.0_fc-0.M6.14.
Comment 9 Aaron Luchko 2005-05-04 14:17:34 EDT
Comment on attachment 110361 [details]
error log

Unfortunately this isn't generating any kind of log file (the original one must
of been unrelated). The version is 3.1.0_fc-0.M6.14.
Comment 10 Andrew Overholt 2005-05-12 13:40:37 EDT
Just to clarify, this doesn't happen with the IBM JVM (and presumably other
proprietary JVMs).
Comment 11 Andrew Overholt 2005-05-12 14:24:08 EDT
This is another miscompilation 'cause it doesn't happen when I temporarily
remove my classmap.db.  I guess we need to figure out what mis-compiled jar is
causing it.  Changing summary.

gcc*4.0.0-4
eclipse*3.1.0_fc-0.M6.16 (this is M6.15 with Ben's -g added to get debuginfo)
Comment 12 Ben Konrath 2005-05-12 20:14:16 EDT
Moving org.eclipse.ui.forms_3.1.0.jar.so out of the way fixes the problem. I'll
disable this plugin in the RPM and push another build (probably tomorrow).
Comment 13 Robin Green 2005-05-15 18:43:59 EDT
Ben - you forgot to comment it out in %files, so you broke the build :)
Comment 14 Ben Konrath 2005-05-16 12:29:37 EDT
Thanks, it's fixed in cvs.
Comment 15 Andrew Overholt 2005-06-08 13:46:31 EDT
This still happens as of gcc 4.0.0-11.
Comment 16 Andrew Overholt 2005-10-08 15:13:37 EDT
I've re-enabled this in the build that will show up in rawhide soon
(3.1.0_fc-15) as I've tested it and with the latest gcc (4.0.2-3), and it's fixed.
Comment 17 Ben Konrath 2006-01-04 12:12:41 EST
Confirming this fix in updates-testing with the following package versions:

gcc-4.0.2-8.fc4
eclipse-platform-3.1.1-1jpp_1fc.FC4.1
Comment 18 Ben Konrath 2006-01-04 14:19:04 EST
Correction, the eclipse package that has the fix is:

eclipse-platform-3.1.1-1jpp_1fc.FC4.11

Note You need to log in before you can comment on or make changes to this bug.