Bug 1464642 - cert update should be minimal impact
cert update should be minimal impact
Status: CLOSED DUPLICATE of bug 1451927
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-24 02:59 EDT by Kenjiro Nakayama
Modified: 2017-06-26 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 04:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2017-06-24 02:59:39 EDT
Description of problem:
--
- When users need to update cert, they want to make the impact minimal. 
- For example, when master.etcd-ca.crt has been expired, it seems we need to use redeploy-openshift-ca.yml. It means that all services including etcd, masters, nodes and docker have to be restarted. That's not good UX and cannot use for critical system.

Version-Release number of selected component (if applicable):
---
- 3.x

How reproducible:
---
- 100%

Steps to Reproduce:
---
1. Update master.etcd-ca.crt by using redeploy-openshift-ca.yml.

Actual results:
---
- All service are restarted.

Expected results:
---
- Not all services are rebooted.

- There are several options:
 a) playbook updates only master.etcd-ca.crt (or all of each certs).
 b) use current redeploy-openshift-ca.yml but restart operations can be conducted manually after the cert update.
Comment 1 Josep 'Pep' Turro Mauri 2017-06-26 04:46:08 EDT

*** This bug has been marked as a duplicate of bug 1451927 ***

Note You need to log in before you can comment on or make changes to this bug.