Bug 1464693 - Path in service file does not get substituted
Path in service file does not get substituted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: zeitgeist (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
:
: 1575233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-24 11:39 EDT by Göran Uddeborg
Modified: 2018-05-18 23:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: zeitgeist-1.0-5.fc28 zeitgeist-1.0-5.fc27 zeitgeist-1.0-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-30 02:46:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2017-06-24 11:39:12 EDT
Description of problem:
From the logs:
jun 24 17:30:36 freddi systemd[30846]: /usr/lib/systemd/user/zeitgeist-fts.service:7: Executable path is not absolute, ignoring: @libexecdir@/zeitgeist-fts
jun 24 17:30:36 freddi systemd[30846]: zeitgeist-fts.service: Service lacks both ExecStart= and ExecStop= setting. Refusing.


Version-Release number of selected component (if applicable):
zeitgeist-1.0-2.fc26.x86_64


How reproducible:
Every login


Steps to Reproduce:
1. Log in and check the logs.


Actual results:
The above error messages.


Expected results:
No error messages in the log.


Additional info:
The problematic line in /usr/lib/systemd/user/zeitgeist-fts.service looks like this:

ExecStart=@libexecdir@/zeitgeist-fts

Obviously, @libexecdir@ should have been expanded to /usr/libexec/zeitgeist some time during the build.
Comment 2 Fedora Update System 2017-09-21 11:33:14 EDT
zeitgeist-1.0-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-00f3d77405
Comment 3 Fedora Update System 2017-09-21 19:59:46 EDT
zeitgeist-1.0-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-00f3d77405
Comment 4 "FeRD" (Frank Dana) 2017-09-22 20:21:36 EDT
Can this be built for f26 as well, please?
Comment 5 Fedora Update System 2017-09-30 02:46:45 EDT
zeitgeist-1.0-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2018-05-08 12:36:33 EDT
zeitgeist-1.0-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8cccae7e59
Comment 7 David King 2018-05-08 12:36:53 EDT
*** Bug 1575233 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2018-05-09 18:27:47 EDT
zeitgeist-1.0-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8cccae7e59
Comment 9 udo 2018-05-10 01:48:00 EDT
Where can we find python2-zeitgeist in a version that fits this Fedora 26 release?
Comment 10 "FeRD" (Frank Dana) 2018-05-10 01:54:53 EDT
(In reply to udo from comment #9)
> Where can we find python2-zeitgeist in a version that fits this Fedora 26
> release?

python2-zeitgeist-1.0-3 was generated as part of the same koji build https://koji.fedoraproject.org/koji/buildinfo?buildID=1080334

Its download URL is:
https://kojipkgs.fedoraproject.org//packages/zeitgeist/1.0/3.fc26/noarch/python2-zeitgeist-1.0-3.fc26.noarch.rpm
Comment 11 "FeRD" (Frank Dana) 2018-05-10 01:56:56 EDT
(From the logs it looks like python2-zeitgeist-1.0-3 SHOULD also be in the f26 updates-testing repo, though, alongside zeitgeist-1.0-3.)
Comment 12 Fedora Update System 2018-05-18 23:07:19 EDT
zeitgeist-1.0-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.