Bug 1464710 - ACROREAD (Adobe Reader), install unsuccessful on FEDORA 26 X86_64 BETA
Summary: ACROREAD (Adobe Reader), install unsuccessful on FEDORA 26 X86_64 BETA
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: adobe-source-libraries
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alec Leamas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-25 00:07 UTC by Andre Gompel
Modified: 2018-04-03 15:38 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1541786 (view as bug list)
Environment:
Last Closed: 2017-12-12 10:32:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Andre Gompel 2017-06-25 00:07:05 UTC
Installed as in previous Version (Fedora 25), documented here:

https://www.if-not-true-then-false.com/2010/install-adobe-acrobat-pdf-reader-on-fedora-centos-red-hat-rhel/

How reproducible:
Solid


Steps to Reproduce:
1. Install as said above (exactly), same version of acroread.
2. nothing happens
3.

Actual results:
 acroread does not run !


Expected results:


Additional info:

Comment 1 nvwarr 2017-07-17 09:41:11 UTC
I managed to get acroread working on Fedora 26, but it was a bit tricky.

1) Copy the 32-bit shared libraries /lib/ld-linux.so.2 /lib/libblkid.so.1 /lib/libc.so.6 /lib/libdl.so.2 /lib/libexpat.so.1 /lib/libmount.so.1 /lib/libpthread.so.0 /lib/libuuid.so.1 from a Fedora 25 with a working acroread into the /opt/Adobe/Reader9/Reader/intellinux/lib directory of the Fedora 26 system.

2) Edit /opt/Adobe/Reader9/bin/acroread on the Fedora 26 system, changing the line:

        exec ${1+"$@"}

to
        exec /opt/Adobe/Reader9/Reader/intellinux/lib/ld-linux.so.2 ${1+"$@"}

3) Copying the .adobe directory from my home on the Fedora 25 system to the Fedora 26 one. Without this step it started but gave the message "Unable to initialize user interface".

4) Install libxml2.i686 gdk-pixbuf2-xlib.i686 gtk.i686

I note that installing gtk-murrine-engine.i686 and adwaita-gtk2-theme.i686 gets rid of a whole load of warnings, but doesn't seem to be necessary.

Comment 2 Emmanuel Bigler 2017-07-18 16:06:34 UTC
Hi!
This does not help very much under x86_64, but I just checked that
Adobe Acrobat Reader version linux runs properly under 32-bit Fedora 26 i386 without any special action.
Package installed successfully under i386 fedora 26:
http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i486linux_enu.rpm
Actually the package had been installed several years ago and has been preserved inside /opt/Adobe anytime I upgraded Fedora, and so far, so good ... for i386.

However, I did not manage to get it running under X86_64 Fedora 26 [for me it worked under x86_Fedora up to 25], but I'm not sure to have the proper versions of requested libraries as mentioned by nvwarr in the previous post. 
Thanks for the help!

--
Emmanuel

Comment 3 nvwarr 2017-07-19 07:25:55 UTC
Sorry, I didn't say explicitly, but I am using x86_64. Acroread itself is only 32-bit, so it needs the 32-bit libraries, but thanks to multilib support, these can coexist with the 64-bit ones. This means you need the 32-bit libraries from the Fedora 25 system. i.e. the ones provided by: expat-2.2.1-1.fc25.i686, glibc-2.24-9.fc25.i686, libblkid-2.28.2-2.fc25.i686, 
libmount-2.28.2-2.fc25.i686 and libuuid-2.28.2-2.fc25.i686. NOT the x86_64 ones.

The rpm provided by Adobe has some libraries in it, but not all. Some change in the libraries, which are not shipped by Adobe, and therefore taken from the Fedora distribution, must have changed between F25 and F26, so they break acroread. The workaround is to pull in old versions of those libraries too, but the ld-linux.so.2 hack is also needed.

It might be better still to use libraries from a version that is contemporary with the Adobe rpm. I have the impression that some other features are no longer working on Fedora 25, but I don't remember if they ever did work. However, it is possible that they were broken by a previous library upgrade.

I note that people have reported that only the first two steps are needed if you are upgrading a setup, which worked before an upgrade of Fedora. You only need all four if you do a fresh install.

I note also that the reason why it doesn't work on a fresh install without copying the stuff from the user's home directory seems to be due to the reader_prefs file. If I use the one, which ships with acroread, I get the "Unable to initialize user interface", but if I use the one from a working system, it is fine. The two files are _completely_ different. The one from the working system is one, which acroread has saved itself.

Comment 4 Gregor Hlawacek 2017-08-05 07:00:05 UTC
Thanks for the hint on copying the libraries from F25. However, I am using version 9.4.1 as this is the last version that is able to play embedded videos which I use for my LaTeX presentations. While acroread works in general it silently crashes once I try to show a video.

Comment 5 nvwarr 2017-08-07 08:41:38 UTC
Try copying /lib/libICE.so.6 and /lib/libXt.so.6 as well.

Comment 6 Gregor Hlawacek 2017-08-07 19:47:55 UTC
Thanks a lot that solved the problem. Embedded videos work again.

Does anyone know what actually has changed.

Gregor

Comment 7 Lonni J Friedman 2017-08-07 19:53:12 UTC
Fedora changed.  It no longer has the versions of libraries that acrobat expects.  The only way to truly fix this is for Adobe to release an updated acrobat reader. It seems unlikely that's going to happen, considering how they've not updated the reader in years, and actually deprecated it on other OS's.

Comment 8 Hin-Tak Leung 2017-08-25 02:19:00 UTC
Hmm, pleasantly surprised that it now runs on fedora 26! It did not, the last time I tried (within the last 18 days - my fedora 26 is a new install and only that old) - hence I have left open this bug report for closer look later.

Comment 9 Hin-Tak Leung 2017-08-25 02:30:17 UTC
Oh, a few other people on
https://forums.fedoraforum.org/showthread.php?t=314745
noticed that acroread started to work after the bunch of upgrade on 21st August. So I am not being lucky alone.

Comment 10 Fedora End Of Life 2017-11-16 15:44:47 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 11 Fedora End Of Life 2017-12-12 10:32:52 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 12 Tomcombi 2018-03-08 09:27:15 UTC
nice

Comment 13 Tomcombi 2018-03-08 09:27:29 UTC
nice

Comment 14 Gregor Hlawacek 2018-03-08 14:29:37 UTC
Not working on F27


Note You need to log in before you can comment on or make changes to this bug.