Bug 1464727 - glusterd: crash on parsing /proc/<pid>/cmdline after node restart after ungraceful shutdown
glusterd: crash on parsing /proc/<pid>/cmdline after node restart after ungra...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Mohit Agrawal
Bala Konda Reddy M
3.3.0-devel-freeze-exception
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-25 01:58 EDT by Milind Changire
Modified: 2017-09-21 01:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-32
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 01:02:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Atin Mukherjee 2017-06-26 02:57:32 EDT
Can you please attach the core along with 't a a bt' output?
Comment 3 Atin Mukherjee 2017-06-26 02:59:04 EDT
I think this can be addressed as part of https://review.gluster.org/#/c/17601/

Mohit - thoughts?
Comment 4 Milind Changire 2017-06-26 03:24:39 EDT
(In reply to Atin Mukherjee from comment #2)
> Can you please attach the core along with 't a a bt' output?

There was a backtrace in /var/log/glusterfs/glusterd.log, which I have printed using my print-backtrace.sh to get the line numbers resolved. There's no core file that got dumped.

The resolved backtrace is available at comment #0 under Additional Info
Comment 5 Atin Mukherjee 2017-06-27 00:02:41 EDT
upstream patch : https://review.gluster.org/#/c/17601/
Comment 8 Atin Mukherjee 2017-06-27 10:04:26 EDT
upstream patch : https://review.gluster.org/#/c/17601/
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/110184/
Comment 10 Bala Konda Reddy M 2017-07-17 02:31:00 EDT
BUILD: 3.8.4.32

Followed the steps mentioned by Milind, performed kill -9 on the brick process and glusterd and restarted glusterd on a node. No glusterd crash is seen. Hence marking it as verified.
Comment 12 errata-xmlrpc 2017-09-21 01:02:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.