Bug 1464736 - Can no longer create spins with livecd-creator
Can no longer create spins with livecd-creator
Status: CLOSED DUPLICATE of bug 1464843
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
26
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Neal Gompa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 04:33 EDT by Boyd
Modified: 2017-06-30 17:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 17:38:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boyd 2017-06-25 04:33:47 EDT
Description of problem:  livecd-creator seems to no longer find repositories in F26.  Outputs error:  

Failed to synchronize cache for repo 'fedora', disabling.
Failed to synchronize cache for repo 'updates', disabling.
Error creating Live CD : Failed to find group 'core' : no such group


Version-Release number of selected component (if applicable):  livecd-tools-24.4.1


How reproducible:  Try to create any spin with livecd-creator


Steps to Reproduce:
1. cd /usr/share/spin-kickstarts/
2. sudo livecd-creator -c fedora-live-workstation.ks -f Fedora-Workstation
3.

Actual results:
/usr/lib/python3.6/site-packages/pykickstart/commands/partition.py:330: UserWarning: A partition with the mountpoint / has already been defined.
  warnings.warn(_("A partition with the mountpoint %s has already been defined.") % pd.mountpoint)
['/sbin/mkfs.ext4', '-F', '-L', '_iso/Fedora-Workstation', '-m', '1', '-b', '4096', '/dev/loop0']
Skipping (/sys/fs/selinux,/sys/fs/selinux) because source doesn't exist.
Failed to synchronize cache for repo 'fedora', disabling.
Failed to synchronize cache for repo 'updates', disabling.
Error creating Live CD : Failed to find group 'core' : no such group



Expected results:  livecd-creator will create livecd


Additional info: livemedi-creator does the same.
Comment 1 Corey Sheldon 2017-06-25 19:36:33 EDT
This is with packaged fedora-kickstarts for $arch.fc26 ? or the git repo, moved into /usr/share/spin-kickstarts?
Comment 2 Boyd 2017-06-26 11:46:49 EDT
This is with the fedora packaged kickstarts.  None of them work.  Seems to not find the repos, but otherwise dnf is OK.
Comment 3 Neal Gompa 2017-06-30 17:38:16 EDT
This is actually a DNF bug, see bug 1464843.

The fix is in upstream DNF: https://github.com/rpm-software-management/dnf/commit/197e13802200523200f779db5a55eb8d3bd3e425

Please separately request this to be backported to DNF in F26 stable.

*** This bug has been marked as a duplicate of bug 1464843 ***

Note You need to log in before you can comment on or make changes to this bug.