Bug 1464750 - [New UI] - New vNIC profile created on the wrong logical network
[New UI] - New vNIC profile created on the wrong logical network
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Unspecified
high Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Ales Musil
Michael Burman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 08:16 EDT by Michael Burman
Modified: 2017-12-20 05:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:45:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
record1 (5.03 MB, application/x-gzip)
2017-06-25 08:16 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79747 master MERGED frontend: Fix new vNIC profile created on the wrong logical network 2017-08-09 08:40 EDT

  None (edit)
Description Michael Burman 2017-06-25 08:16:06 EDT
Created attachment 1291699 [details]
record1

Description of problem:
[New UI] - New vNIC profile created on the wrong logical network.

When creating new vNIC profile, it is created on the wrong network. 
It seems that when creating a new vNIC profile under network, it pointing to the first network in the drop down list and not to the chosen/correct network in which you desire to create the vNIC. Because of that, the new vNIC created under the wrong network(the first one in drop down list).

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170624071949.gitff9611b.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Create new network 'net1'
2. Try to create new vNIC profile under 'net1', press the network and create new vNIC profile called 'net11' under 'net1'

Actual results:
New vNIC profile 'net11' was created under network 'ovirtmgmt' and not under network 'net1' as it should.
'ovirtmgmt' was the grayed out network in the drop down list(see record) on the new vNIC dialog and not 'net1' as should to be(cause we choose net1 and not ovirtmgmt). As we choose to create the new vNIC under 'net1'

Expected results:
Must work as expected.
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-26 01:43:25 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Michael Burman 2017-08-21 03:45:29 EDT
Verified on - 4.2.0-0.0.master.20170820180837.git59243e9.el7.centos
Comment 4 Sandro Bonazzola 2017-12-20 05:45:29 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.