Bug 1464795 - Cold Merge: Add an entry describing merge job to audit log
Cold Merge: Add an entry describing merge job to audit log
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.1.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.4
: 4.1.4
Assigned To: Ala Hino
Kevin Alon Goldblatt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 16:48 EDT by Ala Hino
Modified: 2017-07-28 10:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:18:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78628 master MERGED core: Add audit entry with cold merge info 2017-07-03 07:48 EDT
oVirt gerrit 78964 ovirt-engine-4.1 MERGED core: Add audit entry with cold merge info 2017-07-04 08:37 EDT

  None (edit)
Description Ala Hino 2017-06-25 16:48:04 EDT
Description of problem:
In the fix of BZ 1420401, we showed the cold merge info (base and top volume names and the host running the merge job) in the UI in the tasks panel (and obviously in engine log file).
This bug is to address a request to add same info to audit log.

How reproducible:
100%

Steps to Reproduce:
Run cold merge

Actual results:
No entry added to audit log (audit_log table in the database)

Expected results:
An entry with merge job info to be added to audit log table. Following is a sample message:

"
Merging snapshots (vm03-s1 into vm03-s2) of disk vm03_Disk1 on host rich-el73-host01
"
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-25 16:49:22 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Kevin Alon Goldblatt 2017-07-11 09:35:37 EDT
Verified with the following code:
---------------------------------------
ovirt-engine-4.1.4-0.2.el7.noarch
rhevm-4.1.4-0.2.el7.noarch
vdsm-4.19.21-1.el7ev.x86_64


Verified with the following scenario:
---------------------------------------
1. Create Vm with disk
2. Create 3 snapshots snapt1, snapt2, snapt3
3. While vm is down perform cold merge by deleting snapshot snapt2 >>>>> An entry is added to the audit log as follows:

Merging snapshots (snapt3 into snapt2) of disk GlanceDisk-d8282c2 on host purple-vds1.qa.lab.tlv.redhat.com


Moving to VERIFIED!

Note You need to log in before you can comment on or make changes to this bug.