Bug 1464838 - qemu records an undocumented field "=keyvalue-pairs" in overlay image of a RBD volume after snapshot
qemu records an undocumented field "=keyvalue-pairs" in overlay image of a RB...
Status: CLOSED DUPLICATE of bug 1464837
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 22:56 EDT by Han Han
Modified: 2017-08-01 03:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 02:48:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Han Han 2017-06-25 22:56:40 EDT
Description of problem:
As subject

Version-Release number of selected component (if applicable):
libvirt-3.2.0-15.el7a.x86_64
qemu-kvm-rhev-2.9.0-14.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
According to the last sentence in https://bugzilla.redhat.com/show_bug.cgi?id=1461638#c16, I file this bug.
1. Run a VM with rbd backend
2. Create external snapshot for the rbd disk
3. Do blockcommit. You will find <host/> missing in VM's xml.

Actual results:
As step3

Expected results:
<host/> is not missing

Additional info:
Comment 2 Han Han 2017-06-25 23:02:49 EDT
Hi Peter,
Since time is tight to fix it in 7.4, we should add this as known issue of release note and offer https://bugzilla.redhat.com/show_bug.cgi?id=1461638#c17 as workaround. What do you think?
Comment 3 Peter Krempa 2017-06-26 02:33:16 EDT
It might be a good idea to do this. This is a bug in qemu though so I'll move it.
Comment 4 Peter Krempa 2017-06-26 02:36:11 EDT
The string recorded in the overlay image by qemu after a snapshot is:

json:{"driver": "raw", "file": {"pool": "rbd", "image": "V", "driver": "rbd", "=keyvalue-pairs": "[\"auth_supported\", \"none\", \"mon_host\", \"10.73.75.52\"]"}}

As seen, this does not contain the 'server' section, but contains an undocumented "=keyvalue-pairs".
Comment 5 Han Han 2017-06-26 02:48:21 EDT
Since the bug moved to qemu, duplicated with BZ1464837

*** This bug has been marked as a duplicate of bug 1464837 ***

Note You need to log in before you can comment on or make changes to this bug.