This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 146487 - Serial installs newly broken
Serial installs newly broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: booty (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
: FutureFeature
Depends On:
Blocks: RHEL3U8CanFix
  Show dependency treegraph
 
Reported: 2005-01-28 14:58 EST by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0444
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 10:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2005-01-28 14:58:48 EST
Description of problem:

anaconda from RHEL3 U4 now correctly puts "console=ttyS#,9600n81" in
grub.conf when the machine gets installed over a serial port.  This is
a step in the right direction, but it doesn't allow for full
functionality when a keyboard and monitor are plugged into the machine.  

Could you make the change due to a serial install be to append
"console=ttyS#,9600n81 console=tty0"  instead?
Comment 1 Joshua Jensen 2005-01-28 15:13:53 EST
err... I got that backwards.... it should be:

console=tty0 console=ttyS#,9600n81
Comment 2 Joshua Jensen 2005-06-06 12:15:18 EDT
ping
Comment 4 Peter Jones 2005-08-25 16:43:27 EDT
Agreed, that'd be better, but at the same time it's unlikely this will be fixed
for RHEL 3, since there are a number of obvious workarounds and there's no
reason it would be a showstopper bug for u7.

This is trivial to fix with e.g. sed in your %post, or to fix by hand after
installation.
Comment 5 Joshua Jensen 2005-08-25 19:16:38 EDT
This should also be trivial to fix in anaconda.  Getting every customer to work
around a known bug that keeps them from using a local monitor and keyboard isn't
ideal.  How about RHEL3 U8 ?
Comment 13 Bob Johnson 2006-04-11 11:57:17 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.
Comment 15 Joshua Jensen 2006-05-01 15:32:02 EDT
Excellent... thank you Red Hat.
Comment 17 Red Hat Bugzilla 2006-07-20 10:59:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0444.html

Note You need to log in before you can comment on or make changes to this bug.