Bug 1464881 - Getting "password component depends user component" error while refreshing manifest
Getting "password component depends user component" error while refreshing ma...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.2.10
x86_64 All
high Severity high (vote)
: 6.2.11
: 6.2
Assigned To: Chris Roberts
Renzo Nuccitelli
http://projects.theforeman.org/issues...
: PrioBumpGSS, Regression, Triaged
Depends On:
Blocks: 1469692
  Show dependency treegraph
 
Reported: 2017-06-26 03:41 EDT by Hao Chang Yu
Modified: 2018-01-04 08:23 EST (History)
21 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.140-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1469692 (view as bug list)
Environment:
Last Closed: 2017-08-10 13:02:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20216 None None None 2017-07-05 09:37 EDT
Red Hat Knowledge Base (Solution) 3093191 None None None 2017-06-26 19:27 EDT

  None (edit)
Comment 1 Amit Kumar Das 2017-06-26 03:49:05 EDT
There is code difference in determining the string value.

satellite 6.2.9 <<<----katello-3.0.0.125
satellite 6.2.10 <<<---katello-3.0.0.137


# diff candlepin.rb.629 candlepin.rb.6210
274,276c274,276
<             uri.port = proxy_config[:port]
<             uri.user = proxy_config[:user]
<             uri.password = proxy_config[:password]
---
>             uri.port = proxy_config[:port].to_s
>             uri.user = proxy_config[:user].to_s
>             uri.password = proxy_config[:password].to_s
Comment 3 Hao Chang Yu 2017-06-26 03:55:50 EDT
Make the following change seems to fix the issue:

uri.port = proxy_config[:port].to_s if proxy_config[:port]
uri.user = proxy_config[:user].to_s if proxy_config[:user]
uri.password = proxy_config[:password].to_s if proxy_config[:password]
Comment 6 Renzo Nuccitelli 2017-07-25 09:46:37 EDT
Manifest refresh worked both through UI and hammer:

hammer> subscription refresh-manifest --organization-id 1
[......................................................................] [100%]

So I am moving this to VERIFIED.
Comment 8 errata-xmlrpc 2017-08-10 13:02:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2466

Note You need to log in before you can comment on or make changes to this bug.