Bug 146489 - [indic] Indic dependent vowel's assumption on character cluster
[indic] Indic dependent vowel's assumption on character cluster
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pango (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pravin Satpute
desktop-bugs@redhat.com
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2005-01-28 15:06 EST by Leon Ho
Modified: 2010-02-02 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 17:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 345069 None None None Never

  None (edit)
Description Leon Ho 2005-01-28 15:06:54 EST
Description of problem:
When typing dependent vowel without any consonants, it will assume the
previous char was consonant.

Version-Release number of selected component (if applicable):
1.6.0-7

How reproducible:
everytime

Steps to Reproduce:
1. type "a"
2. type "ो"
3a. press backspace
3b. press left arrow-key
  
Actual results:
a. 'a' get deleted along with the devanagari vowel sign
b. the cursor position located before 'a'

Expected results:
a. only the vowel sign get deleted
b. only moves before vowel sign

Additional info:
Comment 1 Leon Ho 2005-01-31 15:27:31 EST
Will post it on upstream.
Comment 2 Matthias Clasen 2006-06-20 01:16:06 EDT
Reassigning pango bugs to Behdad.
Comment 3 Liang Zhang 2006-06-28 22:07:30 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=345069
Comment 4 Liang Zhang 2006-07-27 04:09:07 EDT
I wrote a patch for this bug.
http://bugzilla.gnome.org/show_bug.cgi?id=345069
Comment 5 Jens Petersen 2008-04-30 20:42:04 EDT
Is this still a problem?
Comment 6 Jens Petersen 2009-07-10 05:07:43 EDT
Pravin, an old bug but could you check the current status of this one?
Comment 7 Pravin Satpute 2009-07-10 08:28:44 EDT
still bug exist in RHEL 5, F11 and Rawhide as well
no RHEL 4 system to test :(
i will install it on monday and update as well
Comment 8 Jens Petersen 2009-07-12 22:35:41 EDT
That's fine - if there is no fedora bug open we should clone this to Fedora and fix it there first.
Comment 9 Pravin Satpute 2009-07-14 00:12:44 EDT
we have upstream bug open for this, will work on that
Comment 10 Jens Petersen 2010-02-02 17:16:49 EST
Closing this out: http://bugzilla.gnome.org/show_bug.cgi?id=345069 got closed.

Note You need to log in before you can comment on or make changes to this bug.