Bug 1464932 - Error 503 and 504 on Hawkular Cassandra query
Error 503 and 504 on Hawkular Cassandra query
Status: CLOSED DUPLICATE of bug 1457499
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity high
: ---
: 3.7.0
Assigned To: Matt Wringe
Junqi Zhao
: OpsBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 05:16 EDT by Gabor Burges
Modified: 2017-08-04 15:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 15:16:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabor Burges 2017-06-26 05:16:51 EDT
Description of problem:

Metrics is in Unhealthy state, and produces Error 504 gateway time out or 503 Service unavailable. The pods are in running state 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
NAME                         READY     STATUS    RESTARTS   AGE
hawkular-cassandra-1-u0l23   1/1       Running   2          31d
hawkular-cassandra-2-20ll2   1/1       Running   1          31d
hawkular-metrics-t1u9m       1/1       Running   3          31d
heapster-tjzol               1/1       Running   4          108d

oc version
oc v3.4.1.18
kubernetes v1.4.0+776c994
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://internal.api.evg.openshift.com
openshift v3.4.1.18
kubernetes v1.4.0+776c994

Running command: ['oc', '--config', '/tmp/Z0VCN2X', '-n', 'openshift-infra', 'get', 'route', 'hawkular-metrics', '-o', 'yaml']
ERROR - Failed to query hawkular - HTTP Error 504: Gateway Time-out
ERROR - Failed to query hawkular - HTTP Error 504: Gateway Time-out
ERROR - Failed to query hawkular - HTTP Error 504: Gateway Time-out
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable
ERROR - Failed to query hawkular - HTTP Error 503: Service Unavailable

Expected results:


Additional info:
Comment 8 Matt Wringe 2017-08-04 15:16:36 EDT
We are marking this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1457499

If you are still encountering this problem after updating, please re-open this issue.

*** This bug has been marked as a duplicate of bug 1457499 ***

Note You need to log in before you can comment on or make changes to this bug.