Bug 1464942 - [3.3]Docker excluder did not protect a right version's docker installed during scaleup master/node
[3.3]Docker excluder did not protect a right version's docker installed durin...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.3.1
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.1
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 05:32 EDT by liujia
Modified: 2017-08-21 23:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 08:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description liujia 2017-06-26 05:32:46 EDT
Description of problem:
Add a new master/node to existed cluster, docker-excluder did not protect docker installed at a right version.

# rpm -qa|grep excluder
atomic-openshift-excluder-3.3.1.46-1.git.0.c15d151.el7.noarch
atomic-openshift-docker-excluder-3.3.1.46-1.git.0.c15d151.el7.noarch

# docker --version
Docker version 1.12.6, build 88a4867/1.12.6

# cat /etc/yum.conf |grep exclude
exclude= tuned-profiles-atomic-openshift-node  atomic-openshift-tests  atomic-openshift-sdn-ovs  atomic-openshift-recycle  atomic-openshift-pod  atomic-openshift-node  atomic-openshift-master  atomic-openshift-dockerregistry  atomic-openshift-clients-redistributable  atomic-openshift-clients  atomic-openshift  docker*1.20*  docker*1.19*  docker*1.18*  docker*1.17*  docker*1.16*  docker*1.15*  docker*1.14*  docker*1.13*  docker*1.12* 



Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.3.101-1.git.0.abe8fc6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Rpm install ocp 3.3 ha env.
2. Prepare a fresh host enabled 3.3 latest repo. 
3. Edit inventory file to add following info:
[OSEv3:children]
...
new_masters
...
[new_masters]
...
[new_nodes]

3. Add a new master to the cluster
# ansible-playbook -i hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-master/scaleup.yml

4. After add new master succeed, add a new node to the cluster
# ansible-playbook -i hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-node/scaleup.yml

Actual results:
Scaleup succeed and both of excluders installed on the new host, but docker version is out of excluded package lists.

Expected results:
Docker should be installed with right version when scaleup master/node.

Additional info:
The root cause should be docker was installed before docker-excluder. I think 3.4 should have the same issue, but not like 3.3, it would not get any bad influence till now, because the latest version is docker-1.12, just below docker-excluder's excluded package lists.

Note You need to log in before you can comment on or make changes to this bug.