Bug 1464957 - [RFE] Simplified RBD client key creation
[RFE] Simplified RBD client key creation
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: rc
: 3.0
Assigned To: Jason Dillaman
Parikshith
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-06-26 05:55 EDT by John Spray
Modified: 2017-12-05 18:34 EST (History)
5 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.2-1.el7cp Ubuntu: ceph_12.1.2-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.Granting access to Ceph Block Device images has been simplified The `ceph auth get-or-create` command now supports two profiles, `rbd` and `rbd-read-only`. When using these profiles, `cephx` capabilities are created automatically without the need to specify them directly. For example, to create a `client.1` user with required capabilities for Monitors and OSDs: ---- ceph auth get-or-create client.1 mon 'profile rbd' osd 'profile rbd [pool=<pool>]' ---- OSDs support the `rbd` and `rbd-read-only` profiles. Monitors support only the `rbd` profile.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:34:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Spray 2017-06-26 05:55:11 EDT
A command for granting access to RBD images in a particular pool, without the user having to touch auth cap syntax.
Comment 4 Jason Dillaman 2017-07-11 10:37:36 EDT
In-progress as part of the Luminous release. RBD clients can now be defined using a simplified syntax:

ceph auth get-or-create client.<ID> mon 'profile rbd' osd 'profile rbd[ pool=<pool>][, profile ...]'

The OSD has two possible profiles: rbd and rbd-read-only
The MON has a single possible profile: rbd
Comment 22 errata-xmlrpc 2017-12-05 18:34:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.