Bug 146498 - up2date isn't Satellite Server Aware
Summary: up2date isn't Satellite Server Aware
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-28 21:23 UTC by nathan r. hruby
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:08:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nathan r. hruby 2005-01-28 21:23:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When prompting for Channels to update, the GUI up2date has a link to
hosted RHN hardcoded into the button for the "To Subscribe or
unsubscribe from channels..." text.  This button actually takes one to
rhn.redhat.com in a mozilla window as well.

This button should instead pick up the config value serverURL and use
it if it is not rhn.redhat.com.

This is going to be a FAQ for many users.

Version-Release number of selected component (if applicable):
up2date-4.2.57-2

How reproducible:
Always

Steps to Reproduce:
1.run up2date as root from a xterm
2.click forward
3.read button in middlw of window
    

Actual Results:  You get a button that sends you to rhn.redhat.com

Expected Results:  You get a button that sends you to the vaule of
serverURL

Additional info:

Comment 1 Suzanne Hillman 2005-02-04 21:38:36 UTC
Internal RFE bug #147223 entered; will be considered for future releases.

Comment 2 nathan r. hruby 2005-05-13 21:33:41 UTC
Hurm.. revisiting becase this is listed in our internal issue tracking system
and I was playing cleanup today and found this one which I had forgotten.

The reason for asking for serverURL to be used if differnt from rhn.redhat.com
is because the current functionality makes up2date confusing for people with a
RHN Satellite.  Specificlly, users are redirected to RHN Hosted which has no
concept of who the site Satellite users are.

Since 147223 is private, could someone please update that bug with this information?

Also, since appears to be a regression in user experince for RHN Satellite
users, I think perhaps this is truly a UI bug instead of an RFE.

Comment 3 Suzanne Hillman 2005-05-16 15:23:33 UTC
Internal RFE updated with additional information.

Comment 4 RHEL Product and Program Management 2007-10-19 19:08:17 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.