Bug 1464981 - [RFE]: Sanitized health check format
[RFE]: Sanitized health check format
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: rc
: 3.0
Assigned To: John Spray
shylesh
Erin Donnelly
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-06-26 07:01 EDT by John Spray
Modified: 2017-12-05 18:35 EST (History)
9 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.Ceph health checks are more easily integrated with external alerting systems Ceph's built-in health checks have been refactored to enable more robust integration with external alerting systems. For each condition that is checked, there is now a unique status code, for example `PG_AVAILABILITY`. NOTE: Any external script that was relying on the JSON syntax of the `ceph status` or `ceph health` command output must be updated for the new format. To ease migration, set the `mon_health_preluminous_compat` parameter to `True` on Monitors to instruct `ceph status` and `ceph health` to generate old-style health output in addition to the new output.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:35:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 7192 None None None 2017-06-26 07:01 EDT

  None (edit)
Description John Spray 2017-06-26 07:01:36 EDT
Each possible WRN/ERR health condition gets a unique code.  Active conditions get a metadata map that enables other UIs to display the message in a way of their choosing and link to relevant items (affected pools, osds etc).

These codes can be used to refer to documentation, and simplify handling the health status output in other UIs.
Comment 3 Josh Durgin 2017-07-18 20:17:13 EDT
No work on this upstream yet.
Comment 4 John Spray 2017-07-19 06:52:36 EDT
This is the health check changes that we landed last week.
Comment 7 John Spray 2017-08-16 07:32:03 EDT
Yes, it's in there.  Just bad housekeeping on my part: I've marked the upstream ticket resolved now.
Comment 17 errata-xmlrpc 2017-12-05 18:35:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.