Bug 1465051 - perl-Authen-CAS-Client-0.07-4.fc27 FTBFS with perl-5.26.0: Can't locate inc/Module/Install.pm in @INC
perl-Authen-CAS-Client-0.07-4.fc27 FTBFS with perl-5.26.0: Can't locate inc/M...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Authen-CAS-Client (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 09:29 EDT by Petr Pisar
Modified: 2017-06-26 10:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Authen-CAS-Client-0.07-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 10:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-06-26 09:29:10 EDT
perl-Authen-CAS-Client-0.07-4.fc27 fails to build in F27 because Perl 5.26.0 removed "." from @INC:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.u1oviC
+ umask 022
+ cd /builddir/build/BUILD
+ cd Authen-CAS-Client-0.07
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor --skipdeps
Can't locate inc/Module/Install.pm in @INC (you may need to install the inc::Module::Install module) (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at Makefile.PL line 4.
BEGIN failed--compilation aborted at Makefile.PL line 4.
Comment 1 Petr Pisar 2017-06-26 09:30:00 EDT
Upstream fixed in in 0.08, but the 0.08 release has bad license. I will fix 0.07 locally.

Note You need to log in before you can comment on or make changes to this bug.