Bug 1465070 - [Regression] Content-view include filter for package adds unwanted packages too to the published version
[Regression] Content-view include filter for package adds unwanted packages t...
Status: CLOSED DUPLICATE of bug 1395642
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
x86_64 Linux
urgent Severity high (vote)
: 6.2.12
: 6.2
Assigned To: Adam Price
: Regression
Depends On:
  Show dependency treegraph
Reported: 2017-06-26 10:41 EDT by vivpatil
Modified: 2017-07-03 10:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-06-30 16:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description vivpatil 2017-06-26 10:41:43 EDT
Description of problem:
Content view include package filter not working as expected while matching the version. When a content view filter is created for a package for e.g "xorg-x11-drv-vmmouse" from RHEL7 Server repository with version equal to "13.0.0-11.el7" it will include all the packages that have the version pattern matching to "13.0.0" in their name . See below

In the issue this the filter for package xorg-x11-drv-vmmouse equals version "13.0.0-11.el7" matches all the above packages when it should only match xorg-x11-drv-vmmouse-13.0.0-11.el7.x86_64.rpm . The issue occurs for other packages too.

Version-Release number of selected component (if applicable):
Satellite 6.2.10

How reproducible:

Steps to Reproduce:
1. Create a content-view with RHEL7 Server repository.
2. Create an Include filter for package xorg-x11-drv-vmmouse that equals to version "13.0.0-11.el7" . And publish a new version. The published version should only contain a single included package. However it contains extra packages as mentioned in the bug description.

Actual results:
The pattern matching within content view filters for package version does not works and includes redundant packages.

Expected results:
Content View should only contain the included packages.

Additional info:
THe issue seems that version is only matched for string before the "-" in the package name.
Comment 1 Edu Alcaniz 2017-06-26 10:56:06 EDT
Setting the flags.
Comment 4 Mike McCune 2017-06-27 08:58:29 EDT
Confirmed this works correctly in 6.1.11 and fails as described in the bug in 6.2.10. Working to determine if this was recently introduced by testing on 6.2.8
Comment 5 Mike McCune 2017-06-27 14:42:20 EDT
Confirmed this also occurs with 6.2.8.
Comment 6 Mike McCune 2017-06-27 14:42:54 EDT
The issue is that we aren't parsing the Release field when doing the filter.
Comment 9 Adam Price 2017-06-30 11:40:36 EDT
found a related bugzilla: 1395642

related redmine: http://projects.theforeman.org/issues/17916
Comment 10 Adam Price 2017-06-30 11:44:00 EDT
err bug 1395642
Comment 13 Mike McCune 2017-06-30 16:46:48 EDT
This is actually a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1395642 which is already resolved.

Will be releasing HOTFIX packages on the above mentioned bug and closing this out as a duplicate.

Follow 1395642 for updates.
Comment 14 Mike McCune 2017-06-30 16:50:01 EDT

*** This bug has been marked as a duplicate of bug 1395642 ***

Note You need to log in before you can comment on or make changes to this bug.