Bug 146509 - missing symbol in libgphoto2_port_usb.so breaks gtkam
missing symbol in libgphoto2_port_usb.so breaks gtkam
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 17:35 EST by Anders Bengtsson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 17:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Bengtsson 2005-01-28 17:35:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After upgrading gphoto2 to version 2.1.5-1.1 I can no longer access my
USB-attached digital camera from gtkam (the GTK front-end of gphoto2).

This is the error message:

gtkam: symbol lookup error:
/usr/lib/gphoto2_port/0.5.1/libgphoto2_port_usb.so: undefined symbol:
usb_get_driver_np


Version-Release number of selected component (if applicable):
gphoto2-2.1.5-1.1

How reproducible:
Always

Steps to Reproduce:
1. Attach camera that previously worked with gtkam to the USB connection
2. Run "gtkam"
3. Wait a few seconds while gtkam starts and loads drivers
4. *poof*


Actual Results:  gtkam crashes, with the error quoted above.

Expected Results:  gtkam should have started.

Additional info:
Comment 1 Tim Waugh 2005-01-31 07:41:02 EST
gtkam is not shipped with Fedora Core 3.  However, that symbol ought to be
present in libusb.

Out of interest, what do these commands say?:

ldd /usr/lib/gphoto2_port/0.5.1/libgphoto2_port_usb.so
nm -D /usr/lib/libusb-0.1.so.4 | grep usb_get_driver
Comment 2 Anders Bengtsson 2005-01-31 17:00:36 EST
Thanks Tim, I found the problem:

libusb-0.1.so.4 => /usr/local/lib/libusb-0.1.so.4 (0x005dd000)

I apparently had an old version of libusb installed in /usr/local/lib that
accidentally worked with the older gphoto2 but not with the newer...
Comment 3 Tim Waugh 2005-01-31 17:05:51 EST
Okay, closing.

Note You need to log in before you can comment on or make changes to this bug.