Bug 1465105 - Note to update satellite-sync cron job to cdn-sync in upgrade docs provided by rhn-upgrade package
Note to update satellite-sync cron job to cdn-sync in upgrade docs provided b...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
580
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tomáš Kašpárek
Ales Dujicek
:
Depends On:
Blocks: sat58-errata
  Show dependency treegraph
 
Reported: 2017-06-26 12:32 EDT by Candace Sheremeta
Modified: 2017-10-19 07:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhn-upgrade-5.8.0.28-1-sat
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-19 07:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-1465105-advise-users-to-change-cron-jobs-to-cdn-sync.patch (786 bytes, patch)
2017-08-17 04:15 EDT, Tomáš Kašpárek
no flags Details | Diff

  None (edit)
Description Candace Sheremeta 2017-06-26 12:32:46 EDT
Hi all,

Although there is information about the syntax of the cdn-sync nightly cron job here: https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html/user_guide/chap-automatically_synchronizing_the_red_hat_satellite_server_repository

We are seeing customers who upgrade from a previous version of Satellite 5.x to Satellite 5.8 who are not changing this cron job. Therefore, their satellite-sync cron job is still running, and giving errors such as these in rhn_server_satellite.log:

2017/06/26 01:14:35 -04:00 Commandline: ['/usr/bin/satellite-sync', '--email', '--traceback-mail=user@example.com']
2017/06/26 01:14:35 -04:00 Red Hat Satellite - live synchronization
2017/06/26 01:14:35 -04:00 ERROR: Live content synchronizing with RHN Classic Hosted is no longer supported.
Please use the cdn-sync command instead unless you are attempting to sync from another Satellite via Inter-Satelite-Sync (ISS), or from local content on disk via Channel Dump ISOs.

Would it be possible to add a note to the upgrade documentation that is provided by the rhn-upgrade RPM telling the customer to please change their nightly satellite-sync job from:

0 1 * * * perl -le 'sleep rand 9000' && satellite-sync --email >/dev/null 2>1

to:

0 1 * * * perl -le 'sleep rand 9000' && cdn-sync --email >/dev/null 2>1

I think this would prevent a LOT of support cases. Thank you so much!
Comment 1 Tomas Lestach 2017-06-27 05:25:38 EDT
Sat 5.7 User Guide really suggests to set up a cron job for periodic content synchronization:
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html/User_Guide/chap-Automatically_Synchronizing_the_Red_Hat_Satellite_Server_Repository.html


Based on this - yes - it makes sense to extend rhn-upgrade instructions with an extra note to update the cron job.
Comment 3 Tomáš Kašpárek 2017-08-17 04:15 EDT
Created attachment 1314591 [details]
0001-1465105-advise-users-to-change-cron-jobs-to-cdn-sync.patch

0001-1465105-advise-users-to-change-cron-jobs-to-cdn-sync.patch
Comment 10 errata-xmlrpc 2017-10-19 07:59:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2914

Note You need to log in before you can comment on or make changes to this bug.