Bug 1465133 - Invalid network plugin name does not cause master process fail
Invalid network plugin name does not cause master process fail
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ben Bennett
Meng Bo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 13:57 EDT by Vikas Laad
Modified: 2017-06-26 20:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 20:20:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikas Laad 2017-06-26 13:57:02 EDT
Description of problem:
Making network plugin name invalid in master-config and restarting master process, master process start does not fail.

Version-Release number of selected component (if applicable):
openshift v3.6.116
kubernetes v1.6.1+5115d708d7
etcd 3.2.0


How reproducible:
always

Steps to Reproduce:
1. create a cluster with valid network plugin
2. modify network plugin in master-config to invalid value
3. restart master process

Actual results:
Master process restart does not fail

Expected results:
Master process start should fail.
Comment 1 Mike Fiedler 2017-06-26 17:50:30 EDT
A network plugin with an invalid name does cause the atomic-openshift-node process to fail on startup.
Comment 2 Ben Bennett 2017-06-26 20:20:10 EDT
Since people can install arbitrary network plugins, we can't know it is invalid until the node attempts to run it.  The master doesn't use a network plugin (but we recommend that the master machine also have a node setup on it so the machine is part of the SDN).

Note You need to log in before you can comment on or make changes to this bug.