Bug 1465176 - modularity-testing-framework does not work on ppc64 because there is no docker package on ppc64
modularity-testing-framework does not work on ppc64 because there is no docke...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: modularity-testing-framework (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
: Reopened
Depends On: 1315903
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64 PPCTracker
  Show dependency treegraph
 
Reported: 2017-06-26 17:55 EDT by Till Maas
Modified: 2017-08-04 11:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: modularity-testing-framework-0.5.1-2.fc25 modularity-testing-framework-0.5.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 11:18:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jan Ščotka 2017-06-27 03:03:33 EDT
Hi,
already fixed in project by:
https://pagure.io/modularity-testing-framework/c/69f91e3c26f744d14d5bed5e71348ae58c13fb9d?branch=master
has to be rebased to recent version.
    Regards
    Honza
Comment 2 Petr Hracek 2017-06-27 03:59:40 EDT
I would prefer to use Till Maas patch. It is more generic. I will merge it to the upstream.
Comment 4 Jan Ščotka 2017-06-27 04:50:09 EDT
Hi,
I'm not sure that that patch is more generic. It causes that you cannot use MTF on ppc64, but there is only docker as an reason, but You can use MTF everywhere for example with rpm or nspawn module type, just docker module type cannot be used on ppc64.
so that it this patch causes that packages is not shipped on ppc64. it is shame
    Regards
    Honza
Comment 5 Petr Hracek 2017-06-27 07:54:03 EDT
Switching to assigned back. #4 seems reasonable. I would not explicitelly disable builds for ppc64.

Till, what do you thing about comment #4. I vote for using exclusive arch or splitting MTF into several subpackages.
Comment 6 Fedora Update System 2017-06-27 13:27:04 EDT
modularity-testing-framework-0.5.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f174988aba
Comment 7 Till Maas 2017-06-27 17:25:43 EDT
If the patch from comment #1 works it should fix this bug afaics. I did not know that this package would be useful on ppc64. Currently it was not installable there. My goal was to prevent having to retire MTF since it should have been fixed in stable today for the Final Freeze.
Comment 8 Fedora Update System 2017-07-11 08:14:26 EDT
modularity-testing-framework-0.5.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5a0598de49
Comment 9 Fedora Update System 2017-07-11 23:22:11 EDT
modularity-testing-framework-0.5.1-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2017-07-12 05:24:33 EDT
modularity-testing-framework-0.5.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5a0598de49
Comment 11 Fedora Update System 2017-08-04 11:18:13 EDT
modularity-testing-framework-0.5.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.