Bug 1465214 - build failed with GF_DISABLE_MEMPOOL
build failed with GF_DISABLE_MEMPOOL
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: coreutils (Show other bugs)
mainline
All All
unspecified Severity high
: ---
: ---
Assigned To: Ji-Hyeon Gim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 21:30 EDT by Ji-Hyeon Gim
Modified: 2017-09-05 13:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:35:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ji-Hyeon Gim 2017-06-26 21:30:49 EDT
Description of problem:

When we build GlusterFS with GF_DISBLE_MEMPOOL, it is failed due to wrong macro condition in mem-pool.c:mem_get().

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-06-26 22:13:05 EDT
REVIEW: https://review.gluster.org/17633 (libglusterfs: build failed with GF_DISABLE_MEMPOOL) posted (#1) for review on master by Ji-Hyeon Gim
Comment 2 Worker Ant 2017-06-27 08:48:58 EDT
COMMIT: https://review.gluster.org/17633 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 68cb9356d19cba5da7f8a719baca47d34e1740b7
Author: Ji-Hyeon Gim <potatogim@gluesys.com>
Date:   Tue Jun 6 11:18:57 2017 +0900

    libglusterfs: build failed with GF_DISABLE_MEMPOOL
    
    When we build GlusterFS with GF_DISBLE_MEMPOOL, it is failed due to macro
    condition in mem-pool.c:mem_get().
    
    Change-Id: I03fe804f93d761ea3bfdc3b20f0253a03350a68f
    BUG: 1465214
    Signed-off-by: Ji-Hyeon Gim <potatogim@potatogim.net>
    Reviewed-on: https://review.gluster.org/17633
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: Ji-Hyeon Gim
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Worker Ant 2017-06-27 10:27:30 EDT
REVIEW: https://review.gluster.org/17636 (libglusterfs: fix disable-mempool) posted (#1) for review on master by Jeff Darcy (jeff@pl.atyp.us)
Comment 4 Jeff Darcy 2017-06-27 10:51:25 EDT
Previous change didn't even fix the compile error (real_sizeof_type comes up undefined).  The regression tests didn't catch this because they don't use the --disable-mempool option.
Comment 5 Worker Ant 2017-06-28 19:27:19 EDT
COMMIT: https://review.gluster.org/17636 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit e9c5b61861299add8bf4b61382611cda68ebb68c
Author: Jeff Darcy <jdarcy@fb.com>
Date:   Tue Jun 27 07:21:28 2017 -0700

    libglusterfs: fix disable-mempool
    
    Change-Id: I55f707ae1e7c3ad7fc0545f7aa657584cead58f9
    BUG: 1465214
    Signed-off-by: Jeff Darcy <jdarcy@fb.com>
    Reviewed-on: https://review.gluster.org/17636
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Jeff Darcy <jeff@pl.atyp.us>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ji-Hyeon Gim
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
Comment 6 Shyamsundar 2017-09-05 13:35:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.