Bug 146522 - input text truncated at 4096 bytes
input text truncated at 4096 bytes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: enscript (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 18:55 EST by David Dillow
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 06:23:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Dillow 2005-01-28 18:55:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Only the first 4096 bytes of the input file are encapsulated in the
postscript output.

I *may* have seen one time where it truncated at a larger size, but I
have been unable to reproduce.

Version-Release number of selected component (if applicable):
enscript-1.6.1-28.0.3

How reproducible:
Always

Steps to Reproduce:
1. echo "This is a test" > t
2. enscript -o t.ps t
3. enscript -o t2.ps t.ps
   
Any input file larger than 4096 bytes will suffice to show the
problem, I just use enscript in step two to build a file.

Actual Results:  t2.ps will be chopped at ~4096 bytes of the input
file, but will be
valid postscript.

Expected Results:  All of t.ps should be output into t2.ps.

Additional info:
Comment 1 Tim Waugh 2005-01-29 07:52:50 EST
A bogus part of the patch to fix CAN-2004-1186 got left in by mistake in the
FC-3 package.  Thanks for bringing this to our attention.

(The FC-2 package is fine.)

Note You need to log in before you can comment on or make changes to this bug.