Bug 1465281 - broken dependency for python-oslo-messaging in Fedora 26
broken dependency for python-oslo-messaging in Fedora 26
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-oslo-messaging (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F26FinalFreezeException
  Show dependency treegraph
 
Reported: 2017-06-27 02:25 EDT by Till Maas
Modified: 2017-07-06 18:49 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-oslo-messaging-5.17.1-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 18:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2017-06-27 02:25:42 EDT
bug for freeze exception process
Comment 1 Fedora Update System 2017-06-27 02:26:50 EDT
python-oslo-messaging-5.17.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-42a589a868
Comment 2 Fedora Blocker Bugs Application 2017-06-27 02:26:52 EDT
Proposed as a Freeze Exception for 26-final by Fedora user till using the blocker tracking app because:

 This fixes a broken dependency in Fedora 26
Comment 3 Alan Pevec 2017-06-27 05:57:58 EDT
What is broken/fixed?

We have bad python3 deps
https://taskotron.fedoraproject.org/artifacts/all/9340b2da-528b-11e7-b258-5254008e42f6/task_output/output.log

I'll fix that now.
Comment 4 Till Maas 2017-06-27 16:20:42 EDT
The problem is this broken dependency:

[python-oslo-messaging]
	python3-oslo-messaging-5.10.0-1.fc26.noarch requires python(abi) = 0:3.5
	python3-oslo-messaging-tests-5.10.0-1.fc26.noarch requires python(abi) = 0:3.5

It is currently broken in F26 because (AFAICS) https://bodhi.fedoraproject.org/updates/FEDORA-2017-42a589a868 is not in stable yet. Since we are now in the Final Freeze a Freeze Exception is needed to get the update in stable. For a Freeze Exception a bug is needed. Therefore I filed the bug and asked for a Freeze Exception so I do not have to retire the package to clean up the final F26 release.
Comment 5 Fedora Update System 2017-06-28 04:51:48 EDT
python-oslo-messaging-5.17.1-2.fc26 python-oslo-utils-3.22.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-42a589a868
Comment 6 Alan Pevec 2017-06-28 08:17:06 EDT
Here is full dnf repoquery --whatrequires "python(abi) = 0:3.5"
on f26:
python3-bsddb3-0:6.2.4-2.fc26.x86_64
python3-django-admin-honeypot-0:1.0.0-1.fc26.noarch
python3-oslo-messaging-0:5.10.0-1.fc26.noarch
python3-oslo-messaging-tests-0:5.10.0-1.fc26.noarch
python3-oslo-middleware-0:3.19.0-1.fc26.noarch
python3-oslo-middleware-tests-0:3.19.0-1.fc26.noarch
python3-oslo-versionedobjects-0:1.8.0-1.fc26.noarch
python3-oslo-versionedobjects-tests-0:1.8.0-1.fc26.noarch

oslo-messaging is fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2017-42a589a868
oslo-middleware by https://bodhi.fedoraproject.org/updates/FEDORA-2017-a047ea02c9 
oslo-versionedobjects by https://bodhi.fedoraproject.org/updates/FEDORA-2017-b93677bf00
Comment 7 Fedora Update System 2017-06-28 15:20:17 EDT
python-oslo-messaging-5.17.1-2.fc26, python-oslo-utils-3.22.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-42a589a868
Comment 8 Adam Williamson 2017-06-29 15:40:22 EDT
Discussed at 2017-06-29 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-06-29/f26-blocker-review.2017-06-29-16.00.html . We agreed that in principle we'll accept all the many 'broken dependency' bugs as FEs, but we will be checking each update carefully to make sure it doesn't introduce any other problems before we push it.
Comment 9 Fedora Update System 2017-07-06 18:49:55 EDT
python-oslo-messaging-5.17.1-2.fc26, python-oslo-utils-3.22.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.