Bug 1465302 - [abrt] [faf] gvfs: recompute_files(): /usr/libexec/gvfsd-network killed by 11
[abrt] [faf] gvfs: recompute_files(): /usr/libexec/gvfsd-network killed by 11
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gvfs (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
http://faf.lab.eng.brq.redhat.com/faf...
:
: 1472371 1510937 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 03:16 EDT by Tomas Pelka
Modified: 2018-04-10 11:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: gvfs-1.30.4-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:01:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 777737 None None None 2017-06-27 05:32 EDT
Red Hat Product Errata RHEA-2018:0836 None None None 2018-04-10 11:02 EDT

  None (edit)
Description Tomas Pelka 2017-06-27 03:16:14 EDT
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/a9cbf0a62d67957ca7ba5c82d15087088da72ce2/

Note for QE, seems to be triggered by gnome-boxes or control-center tests.
Comment 1 Tomas Pelka 2017-06-27 03:17:37 EDT
Another faf that might be related is http://faf.lab.eng.brq.redhat.com/faf/reports/2791/
Comment 2 Tomas Pelka 2017-06-27 03:18:24 EDT
and http://faf.lab.eng.brq.redhat.com/faf/reports/3117/
Comment 3 Ondrej Holy 2017-06-27 05:32:13 EDT
I think that it is a pretty late for 7.4 at this point. I am convinced that this bug isn't anything new, it is there since ever, you just probably changed your tests and it triggers this somehow currently. Thus I think it is not a blocker and it is ok to postpone this to 7.5.

I've already pushed upstream some patches for this crashes [1,2] and it seems it fixes the issue as per the retrace server. The patches from the first bug reports are already part of the rebased gvfs package, the patches from second are not... however the second is not a real fix, just workaround, because I have no idea how this could happen. I need definitely some reproducer to fix it properly...

Can you please provide full backtrace to be sure this is the second issue? Can you please try to figure out what is triggering this issue? May I download the mentioned tests somewhere?

[1] https://bugzilla.gnome.org/show_bug.cgi?id=712235
[2] https://bugzilla.gnome.org/show_bug.cgi?id=777737
Comment 4 Tomas Pelka 2017-06-27 07:11:44 EDT
And this i ok and expected, thanks Ondro.
Comment 5 Ondrej Holy 2017-07-19 07:28:29 EDT
*** Bug 1472371 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Holy 2017-08-09 03:23:38 EDT
Can you please provide me full backtrace of that crash? Can't you please figure out what is concretely causing those crashes and give me some reproducer?
Comment 7 Ondrej Holy 2017-11-10 05:58:48 EST
*** Bug 1510937 has been marked as a duplicate of this bug. ***
Comment 8 Ondrej Holy 2017-11-10 06:04:52 EST
Tentatively the following commit should workaround that issue (see Bug 1510937 for additional info):
https://git.gnome.org/browse/gvfs/commit/?id=d659151

But it would be nice to fix that properly, which requires info about reproducing... Tomas? Vladimir?

We can backport the patch anyway, so setting devel_ack+, but not sure it isn't too late at this point...
Comment 9 Vladimir Benes 2017-11-10 06:38:27 EST
(In reply to Ondrej Holy from comment #8)
> Tentatively the following commit should workaround that issue (see Bug
> 1510937 for additional info):
> https://git.gnome.org/browse/gvfs/commit/?id=d659151
> 
> But it would be nice to fix that properly, which requires info about
> reproducing... Tomas? Vladimir?
> 
> We can backport the patch anyway, so setting devel_ack+, but not sure it
> isn't too late at this point...

It's not late and I am quite unsure how to reproduce, but I can verify the fix in our automation. Could you give me a scratch build?
Comment 10 Ondrej Holy 2017-11-10 08:28:02 EST
The ccpp file provided by Vladimir confirmed that this is caused by dereferencing error variable set to NULL and that the correct fix is the following commit from the same upstream bug report as the workaround:
https://git.gnome.org/browse/gvfs/commit/?id=6a62f4a
https://bugzilla.gnome.org/show_bug.cgi?id=777737
Comment 11 Ondrej Holy 2017-11-10 08:36:09 EST
It seems as per the FAF that there is only one report for RHEL 7.5, so a number of crashes have been probably reduced by the two already included fixes, so this bug is not probably anything urgent...
Comment 13 Pavlin Georgiev 2017-11-13 09:12:04 EST
TEST SETUP
On host wlan-r2s33
under RHEL-7.5-20171110.n.0 Workstation x86_64

Component version:
gvfs-1.30.4-5.el7

TEST PROCEDURE
1. Reserve a test machine with a wireless and network controller.
2. Download the latest package of gvfs from Brew server.
3. Install the package and its dependencies.
4. Run automated tests from TCMS plan 22767
  https://tcms.engineering.redhat.com/plan/22767/ci-control-center-wireless-display-sound#testcases
These were causing issues to 1.30.4-4.el7 and earlier.

RESULTS
Upgrading the component: gvfs
    from: 1.30.4-4.el7
      to: 1.30.4-5.el7
has fixed the bug.
Comment 16 errata-xmlrpc 2018-04-10 11:01:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0836

Note You need to log in before you can comment on or make changes to this bug.