Bug 1465312 - Installation Guide is missing steps for "Removing Life Cycle Environments to Capsule Servers"
Installation Guide is missing steps for "Removing Life Cycle Environments to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.2.10
Unspecified Unspecified
medium Severity medium (vote)
: 6.2.11
: 6.2
Assigned To: Stephen Wadeley
Russell Dickenson
:
Depends On:
Blocks: 1474728
  Show dependency treegraph
 
Reported: 2017-06-27 03:44 EDT by Amit Kumar Das
Modified: 2017-07-27 03:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1474728 (view as bug list)
Environment:
Last Closed: 2017-07-27 03:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Kumar Das 2017-06-27 03:44:01 EDT
Document URL: 
https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/installation_guide/#adding_life_cycle_environments_to_capsule

Section Number and Name: 
4.7.3. Adding Life Cycle Environments to Capsule Servers

Describe the issue: 
Installation Guide is having steps for "Adding Life Cycle Environments to Capsule Servers". But installation Guide is missing steps for "Removing Life Cycle Environments to Capsule Servers". However, that steps are included in server administration guide. 

3.3.4. Removing Life Cycle Environments from Capsule Server

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/server_administration_guide/sect-red_hat_satellite-server_administration_guide-configuring_organizations_locations_and_life_cycle_environments-life_cycle_environments#sect-Red_Hat_Satellite-Installation_Guide-Removing_Life_Cycle_Environments_from_the_Red_Hat_Satellite_Capsule_Server

Suggestions for improvement: 
Merge both add and remove steps in one place for customer's convenience.

Installation Guide - It contains details about "Adding Life Cycle Environments to Capsule Servers", but missing all removal steps.

Server Administration Guide - It contains only removal steps. Good if it has add steps included.
Comment 1 Stephen Wadeley 2017-06-29 03:11:09 EDT
Hello Steve

Move everything to Server Administration Guide? or just copy the Installation Guide section to the Server Administration Guide section? (Removing is not part of installing a Capsule).

Moving to another guide does make sense as Life Cycle Environment is only mentioned in "Configuring a Self-Registered Satellite". It depends on whether having at least one Life Cycle Environment is considered essential to the installation of a Capsule or just its particular application? If it was, it would surely have been added in the Satellite Server section.

A newly installed Sat6 Server does have the Library environment configured by default. If that was the case also for a Capsule, then it would be clear that adding more Life Cycle Environments is a post installation task. Looks like it does:

[root@rhel7-3-sat6-2 ~]# hammer capsule list
---|----------------------------|-----------------------------------------|
ID | NAME                       | URL                                     |
---|----------------------------|-----------------------------------------|
2  | capsule1.example.com       | https://capsule1.example.com:9090       |
1  | rhel7-3-sat6-2.example.com | https://rhel7-3-sat6-2.example.com:9090 |
---|----------------------------|-----------------------------------------|

[root@rhel7-3-sat6-2 ~]# hammer capsule content available-lifecycle-environments \
> --id 2
---|---------|---------------------
ID | NAME    | ORGANIZATION        
---|---------|---------------------
2  | Library | Sat6-CI             
1  | Library | Default Organization




While this bug is being worked on, can we change:
a/ Log in to the Hammer CLI as root. / Log in to the Satellite Server CLI as root. /
Comment 2 Amit Kumar Das 2017-07-11 21:53:23 EDT
Hi,

Can we atleast add a reference in "Server Administration Guide" and mention where to find complete steps about "Adding Life Cycle Environments in capsule" i.e referring to "Installation Guide".

If steps cannot be added then atleast mentioning a reference link will help customer to find a complete steps. When customer refer satellite administration guide, they get confused that only removal steps is mentioned, and they does not know where to find rest of the steps. Adding a reference link to installation guide can be helpful for any further confusion.

Thanks.
Comment 3 Steve Bream 2017-07-12 11:18:02 EDT
I agree that for the sake of completeness we should add the steps for "Adding LIfeCycle Environments" to the Server Administration Guide between "Creating LifeCycle Environments" and "Promoting Content Views".

For the sake of maintainability, I'd like to make this change contingent on the repository unification work that's underway so that we can reuse the existing content on this topic rather than create parallel content.

Thanks,
Steve
Comment 18 Stephen Wadeley 2017-07-27 03:27:30 EDT
Hello


These changes are now live on the customer portal:

Adding Life Cycle Environments to Capsule Servers

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/installation_guide/installing_capsule_server#adding_life_cycle_environments_to_capsule

Note You need to log in before you can comment on or make changes to this bug.